summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-18 06:00:18 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-18 06:00:18 +0000
commit9f752ba70e54556143b7f54d82b3f7be8f858bef (patch)
tree0a9edf8cb0413e4af4446e853c1f022c9cd43c8d /dev-ruby/rubytter
parentVersion bump. Separate USE="examples" from USE="doc". Build and run the stres... (diff)
downloadgentoo-2-9f752ba70e54556143b7f54d82b3f7be8f858bef.tar.gz
gentoo-2-9f752ba70e54556143b7f54d82b3f7be8f858bef.tar.bz2
gentoo-2-9f752ba70e54556143b7f54d82b3f7be8f858bef.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rubytter')
-rw-r--r--dev-ruby/rubytter/ChangeLog9
-rw-r--r--dev-ruby/rubytter/rubytter-1.5.1.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/rubytter/ChangeLog b/dev-ruby/rubytter/ChangeLog
index 0d391d7df7d3..d0085bbc7b5a 100644
--- a/dev-ruby/rubytter/ChangeLog
+++ b/dev-ruby/rubytter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rubytter
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytter/ChangeLog,v 1.6 2012/09/22 06:48:05 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytter/ChangeLog,v 1.7 2013/04/18 06:00:18 graaff Exp $
+
+*rubytter-1.5.1 (18 Apr 2013)
+
+ 18 Apr 2013; Hans de Graaff <graaff@gentoo.org> +rubytter-1.5.1.ebuild:
+ Version bump.
22 Sep 2012; Hans de Graaff <graaff@gentoo.org> rubytter-1.4.2.ebuild:
Update to EAPI=4. Add ruby19.
diff --git a/dev-ruby/rubytter/rubytter-1.5.1.ebuild b/dev-ruby/rubytter/rubytter-1.5.1.ebuild
new file mode 100644
index 000000000000..a70c9b8b24d7
--- /dev/null
+++ b/dev-ruby/rubytter/rubytter-1.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubytter/rubytter-1.5.1.ebuild,v 1.1 2013/04/18 06:00:18 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc examples/*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rubytter is a simple twitter library"
+HOMEPAGE="http://wiki.github.com/jugyo/rubytter"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/json-1.1.3 >=dev-ruby/oauth-0.3.6"
+
+all_ruby_prepare() {
+ sed -i -e '/check_dependencies/ s:^:#:' Rakefile || die
+}