summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-18 07:14:33 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-18 07:14:33 +0000
commit7d37dd922241041bcc0938833a3e463f2ba93a88 (patch)
tree8db13ff0e6d9255e10f972bb05fdb1453decd46e /dev-ruby/storable
parentRemove Text-ParseWords again. It is a core module. (diff)
downloadgentoo-2-7d37dd922241041bcc0938833a3e463f2ba93a88.tar.gz
gentoo-2-7d37dd922241041bcc0938833a3e463f2ba93a88.tar.bz2
gentoo-2-7d37dd922241041bcc0938833a3e463f2ba93a88.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog9
-rw-r--r--dev-ruby/storable/storable-0.8.6.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index 3fdfc0837451..a91877df7dd8 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/storable
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.15 2010/09/09 13:12:42 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.16 2011/02/18 07:14:33 graaff Exp $
+
+*storable-0.8.6 (18 Feb 2011)
+
+ 18 Feb 2011; Hans de Graaff <graaff@gentoo.org> +storable-0.8.6.ebuild:
+ Version bump.
*storable-0.8.2 (09 Sep 2010)
diff --git a/dev-ruby/storable/storable-0.8.6.ebuild b/dev-ruby/storable/storable-0.8.6.ebuild
new file mode 100644
index 000000000000..d13f21e7eecd
--- /dev/null
+++ b/dev-ruby/storable/storable-0.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.6.ebuild,v 1.1 2011/02/18 07:14:33 graaff Exp $
+
+EAPI=2
+
+# jruby → yajl-ruby won't work, as it's compiled extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-*"
+
+# technically, it could work without either; on the other hand, it
+# would break a bit of stuff.
+#ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
+
+# Somehow it infinite-recurse if JSON is used, see issue #1, so use
+# yajl directly.
+ruby_add_rdepend dev-ruby/yajl-ruby
+
+ruby_add_bdepend "test? ( dev-ruby/tryouts:2 )"
+
+all_ruby_prepare() {
+ mv bin examples || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S try || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}