summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-08 09:34:58 +0000
committerTom William Payne <twp@gentoo.org>2003-04-08 09:34:58 +0000
commitb9b5717f3503e69f46c033780a3d224834cb2093 (patch)
treed89a2f89d4212018a7cc29a608802380075e5d9a /dev-ruby/strscan/strscan-0.6.7.ebuild
parentUpdated to 0.6.7 with ebuild fixes (diff)
downloadgentoo-2-b9b5717f3503e69f46c033780a3d224834cb2093.tar.gz
gentoo-2-b9b5717f3503e69f46c033780a3d224834cb2093.tar.bz2
gentoo-2-b9b5717f3503e69f46c033780a3d224834cb2093.zip
Updated to 0.6.7 with ebuild fixes
Diffstat (limited to 'dev-ruby/strscan/strscan-0.6.7.ebuild')
-rw-r--r--dev-ruby/strscan/strscan-0.6.7.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/strscan/strscan-0.6.7.ebuild b/dev-ruby/strscan/strscan-0.6.7.ebuild
new file mode 100644
index 000000000000..2e8429cf89a6
--- /dev/null
+++ b/dev-ruby/strscan/strscan-0.6.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/strscan/strscan-0.6.7.ebuild,v 1.1 2003/04/08 09:34:42 twp Exp $
+
+DESCRIPTION="A library for fast scanning"
+HOMEPAGE="http://i.loveruby.net/en/strscan.html"
+SRC_URI="http://i.loveruby.net/archive/strscan/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+DEPEND=">=dev-lang/ruby-1.6.8"
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+ dodoc README.en doc.en/ChangeLog
+ dohtml doc.en/umanual.html
+}