summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-19 10:16:13 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-19 10:16:13 +0000
commit224d19f1753b7f7b78b0d03cdeb0bf4c47e2643e (patch)
tree0407e1fbdaf75e31e15233c8794db9e182f14745 /dev-ruby/test-unit
parentVersion bump. (diff)
downloadgentoo-2-224d19f1753b7f7b78b0d03cdeb0bf4c47e2643e.tar.gz
gentoo-2-224d19f1753b7f7b78b0d03cdeb0bf4c47e2643e.tar.bz2
gentoo-2-224d19f1753b7f7b78b0d03cdeb0bf4c47e2643e.zip
Version bump. JRuby test failures have been addressed upstream.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.1.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index a8a0a90d0094..af4cda853c9a 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.21 2010/07/03 16:40:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.22 2010/07/19 10:16:13 graaff Exp $
+
+*test-unit-2.1.0 (19 Jul 2010)
+
+ 19 Jul 2010; Hans de Graaff <graaff@gentoo.org> +test-unit-2.1.0.ebuild:
+ Version bump. JRuby test failures have been addressed upstream.
03 Jul 2010; Raúl Porcel <armin76@gentoo.org> test-unit-2.0.9.ebuild:
Add ~ia64/~sparc wrt #324867
diff --git a/dev-ruby/test-unit/test-unit-2.1.0.ebuild b/dev-ruby/test-unit/test-unit-2.1.0.ebuild
new file mode 100644
index 000000000000..51702cf21759
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.0.ebuild,v 1.1 2010/07/19 10:16:13 graaff Exp $
+
+EAPI=2
+# One test fails on jruby, might be a jruby bug
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_intall() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bint/testrb2
+}