summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-06 11:17:42 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-06 11:17:42 +0000
commitb0959407996675b929181687d533991638e39e7b (patch)
tree8a9d537fd994c4aa7a025419e3bc5a5975753f8e /dev-ruby/tidy-ext
parentAdd ruby20 target. (diff)
downloadgentoo-2-b0959407996675b929181687d533991638e39e7b.tar.gz
gentoo-2-b0959407996675b929181687d533991638e39e7b.tar.bz2
gentoo-2-b0959407996675b929181687d533991638e39e7b.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/tidy-ext')
-rw-r--r--dev-ruby/tidy-ext/ChangeLog7
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/tidy-ext/ChangeLog b/dev-ruby/tidy-ext/ChangeLog
index 204d0432d79b..eb2c7121ca9b 100644
--- a/dev-ruby/tidy-ext/ChangeLog
+++ b/dev-ruby/tidy-ext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tidy-ext
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/ChangeLog,v 1.25 2013/01/15 05:26:23 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/ChangeLog,v 1.26 2013/10/06 11:17:42 mrueg Exp $
+
+*tidy-ext-0.1.14-r1 (06 Oct 2013)
+
+ 06 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +tidy-ext-0.1.14-r1.ebuild:
+ Add ruby20 target.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> tidy-ext-0.1.14.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
new file mode 100644
index 000000000000..2fdb3636e149
--- /dev/null
+++ b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tidy-ext/tidy-ext-0.1.14-r1.ebuild,v 1.1 2013/10/06 11:17:42 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension."
+HOMEPAGE="http://github.com/carld/tidy"
+
+LICENSE="HTML-Tidy"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ mkdir lib || die
+
+ # Remove reference to rspec 1
+ sed -i -e '/spec/d' spec/spec_helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/tidy extconf.rb || die "Unable to configure extension."
+}
+
+each_ruby_compile() {
+ emake -Cext/tidy V=1
+ cp ext/tidy/tidy$(get_modname) lib/ || die "Unable to copy extension."
+}