summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-25 09:27:08 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-25 09:27:08 +0000
commit17987fc6f4b6765b37ebb3b772a1daa62b9c45f3 (patch)
tree1d562840ac284271c6c52088add31c868a59a185 /dev-ruby/tilt
parentRemove old version. (diff)
downloadgentoo-2-17987fc6f4b6765b37ebb3b772a1daa62b9c45f3.tar.gz
gentoo-2-17987fc6f4b6765b37ebb3b772a1daa62b9c45f3.tar.bz2
gentoo-2-17987fc6f4b6765b37ebb3b772a1daa62b9c45f3.zip
Version bump. Apply fixes from upstream to pass tests.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/ChangeLog8
-rw-r--r--dev-ruby/tilt/files/tilt-1.3.3-yajl-test.patch33
-rw-r--r--dev-ruby/tilt/tilt-1.3.3.ebuild39
3 files changed, 79 insertions, 1 deletions
diff --git a/dev-ruby/tilt/ChangeLog b/dev-ruby/tilt/ChangeLog
index d147db7b53eb..242fadbe7768 100644
--- a/dev-ruby/tilt/ChangeLog
+++ b/dev-ruby/tilt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tilt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.18 2011/12/25 09:13:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.19 2011/12/25 09:27:08 graaff Exp $
+
+*tilt-1.3.3 (25 Dec 2011)
+
+ 25 Dec 2011; Hans de Graaff <graaff@gentoo.org> +tilt-1.3.3.ebuild,
+ +files/tilt-1.3.3-yajl-test.patch:
+ Version bump. Apply fixes from upstream to pass tests.
25 Dec 2011; Hans de Graaff <graaff@gentoo.org> -tilt-1.2.2.ebuild:
Remove old version.
diff --git a/dev-ruby/tilt/files/tilt-1.3.3-yajl-test.patch b/dev-ruby/tilt/files/tilt-1.3.3-yajl-test.patch
new file mode 100644
index 000000000000..6f81ebcfe040
--- /dev/null
+++ b/dev-ruby/tilt/files/tilt-1.3.3-yajl-test.patch
@@ -0,0 +1,33 @@
+commit c0e076b72e20442cb528010e9436f04a79de1a9b
+Author: Ryan Tomayko <rtomayko@gmail.com>
+Date: Thu Sep 15 00:37:58 2011 -0700
+
+ fix yajl template test failures due to hash (un)order under 1.8
+
+diff --git a/test/tilt_yajltemplate_test.rb b/test/tilt_yajltemplate_test.rb
+index 5226c16..707f97b 100644
+--- a/test/tilt_yajltemplate_test.rb
++++ b/test/tilt_yajltemplate_test.rb
+@@ -11,12 +11,20 @@ begin
+
+ test "compiles and evaluates the template on #render" do
+ template = Tilt::YajlTemplate.new { "json = { :integer => 3, :string => 'hello' }" }
+- assert_equal '{"integer":3,"string":"hello"}', template.render
++ output = template.render
++ result = Yajl::Parser.parse(output)
++ expect = {"integer" => 3,"string" => "hello"}
++ assert_equal expect, result
+ end
+
+ test "can be rendered more than once" do
+ template = Tilt::YajlTemplate.new { "json = { :integer => 3, :string => 'hello' }" }
+- 3.times { assert_equal '{"integer":3,"string":"hello"}', template.render }
++ expect = {"integer" => 3,"string" => "hello"}
++ 3.times do
++ output = template.render
++ result = Yajl::Parser.parse(output)
++ assert_equal expect, result
++ end
+ end
+
+ test "evaluating ruby code" do
diff --git a/dev-ruby/tilt/tilt-1.3.3.ebuild b/dev-ruby/tilt/tilt-1.3.3.ebuild
new file mode 100644
index 000000000000..9d823db460cf
--- /dev/null
+++ b/dev-ruby/tilt/tilt-1.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/tilt-1.3.3.ebuild,v 1.1 2011/12/25 09:27:08 graaff Exp $
+
+EAPI=2
+
+# jruby fails tests
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thin interface over a Ruby template engines to make their usage as generic as possible."
+HOMEPAGE="http://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-yajl-test.patch" )
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit dev-ruby/nokogiri )"
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0"
+
+# Tests fail when markaby is not new enough, but it's optional.
+DEPEND="${DEPEND} !!<dev-ruby/markaby-0.6.9-r1"
+RDEPEND="${RDEPEND}"
+
+all_ruby_prepare() {
+ # Remove rdoc template tests since these are no longer compatible
+ # with newer versions.
+ rm test/tilt_rdoctemplate_test.rb || die
+
+ # Avoid test broken due to hash unordering in ruby 1.8. Fixed upstream.
+ sed -i -e '/template can end with any statement/,/ end/ s:^:#:' test/tilt_yajltemplate_test.rb || die
+}