summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-11 14:09:09 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-11 14:09:09 +0000
commit5be0e828264ccf1cc644af5cd5df8632e65ef6cf (patch)
tree6f64849a824f317187c151e9e9f070350cb06967 /dev-ruby/timecop
parentStable for amd64, wrt bug #433988 (diff)
downloadgentoo-2-5be0e828264ccf1cc644af5cd5df8632e65ef6cf.tar.gz
gentoo-2-5be0e828264ccf1cc644af5cd5df8632e65ef6cf.tar.bz2
gentoo-2-5be0e828264ccf1cc644af5cd5df8632e65ef6cf.zip
Version bump. Fix tests to work on each ruby version. Cleanup old.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/timecop')
-rw-r--r--dev-ruby/timecop/ChangeLog8
-rw-r--r--dev-ruby/timecop/timecop-0.3.5.ebuild28
-rw-r--r--dev-ruby/timecop/timecop-0.5.0.ebuild27
-rw-r--r--dev-ruby/timecop/timecop-0.5.9.2.ebuild33
4 files changed, 40 insertions, 56 deletions
diff --git a/dev-ruby/timecop/ChangeLog b/dev-ruby/timecop/ChangeLog
index 78700e9bd171..13d59787c973 100644
--- a/dev-ruby/timecop/ChangeLog
+++ b/dev-ruby/timecop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/timecop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/ChangeLog,v 1.7 2013/02/16 20:04:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/ChangeLog,v 1.8 2013/09/11 14:09:09 mrueg Exp $
+
+*timecop-0.5.9.2 (11 Sep 2013)
+
+ 11 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +timecop-0.5.9.2.ebuild,
+ -timecop-0.3.5.ebuild, -timecop-0.5.0.ebuild:
+ Version bump. Fix tests to work on each ruby version. Cleanup old.
16 Feb 2013; Agostino Sarubbo <ago@gentoo.org> timecop-0.5.2.ebuild:
Add x86, wrt bug #4437582
diff --git a/dev-ruby/timecop/timecop-0.3.5.ebuild b/dev-ruby/timecop/timecop-0.3.5.ebuild
deleted file mode 100644
index bcdd623eb746..000000000000
--- a/dev-ruby/timecop/timecop-0.3.5.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.3.5.ebuild,v 1.1 2012/02/28 16:52:15 flameeyes Exp $
-
-EAPI="4"
-
-# jruby → one full test fail, that works on theo ther implementations
-USE_RUBY="ruby18 ree18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
-HOMEPAGE="http://github.com/jtrupiano/timecop"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-# tests do not work; the issue has been reported upstream but I have had
-# no answer yet; the use of timecop seems to generally work though.
-RESTRICT=test
diff --git a/dev-ruby/timecop/timecop-0.5.0.ebuild b/dev-ruby/timecop/timecop-0.5.0.ebuild
deleted file mode 100644
index 3d7fa84ff097..000000000000
--- a/dev-ruby/timecop/timecop-0.5.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.5.0.ebuild,v 1.1 2012/09/14 13:47:01 graaff Exp $
-
-EAPI="4"
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.markdown History.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
-HOMEPAGE="http://github.com/jtrupiano/timecop"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-all_ruby_prepare() {
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-}
diff --git a/dev-ruby/timecop/timecop-0.5.9.2.ebuild b/dev-ruby/timecop/timecop-0.5.9.2.ebuild
new file mode 100644
index 000000000000..c66efdd37e1d
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.5.9.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/timecop/timecop-0.5.9.2.ebuild,v 1.1 2013/09/11 14:09:09 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="http://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' test/test_helper.rb || die
+}
+each_ruby_prepare() {
+ sed -i -e "/bin\/sh/ a\RUBY='${RUBY}'" test/run_tests.sh || die
+}