summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-08 12:44:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-08 12:44:55 +0000
commitac03e2194a2cf0a7130b07484cb20ad01919fe1e (patch)
tree82e2eb4a56502f35b0037fe0343c557bf5a89ad2 /dev-ruby/tins
parentInstall a testrb-2 script for us alone, since it's no longer provided by upst... (diff)
downloadgentoo-2-ac03e2194a2cf0a7130b07484cb20ad01919fe1e.tar.gz
gentoo-2-ac03e2194a2cf0a7130b07484cb20ad01919fe1e.tar.bz2
gentoo-2-ac03e2194a2cf0a7130b07484cb20ad01919fe1e.zip
Version bump; this version requires the latest test-unit-2 with the new script, and uses the new support in the eclass for it.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tins')
-rw-r--r--dev-ruby/tins/ChangeLog10
-rw-r--r--dev-ruby/tins/files/tins-0.4.3-gentoo.patch30
-rw-r--r--dev-ruby/tins/tins-0.4.3.ebuild31
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-ruby/tins/ChangeLog b/dev-ruby/tins/ChangeLog
index aec6dd55b2d5..209303983680 100644
--- a/dev-ruby/tins/ChangeLog
+++ b/dev-ruby/tins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/tins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.5 2012/06/10 06:01:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.6 2012/07/08 12:44:55 flameeyes Exp $
+
+*tins-0.4.3 (08 Jul 2012)
+
+ 08 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/tins-0.4.3-gentoo.patch, +tins-0.4.3.ebuild:
+ Version bump; this version requires the latest test-unit-2 with the new
+ script, and uses the new support in the eclass for it.
*tins-0.3.14 (10 Jun 2012)
@@ -25,4 +32,3 @@
25 Dec 2011; Hans de Graaff <graaff@gentoo.org> +tins-0.3.6.ebuild,
+metadata.xml:
Initial import. Successor to dev-ruby/spruz.
-
diff --git a/dev-ruby/tins/files/tins-0.4.3-gentoo.patch b/dev-ruby/tins/files/tins-0.4.3-gentoo.patch
new file mode 100644
index 000000000000..1fae94eb6ab6
--- /dev/null
+++ b/dev-ruby/tins/files/tins-0.4.3-gentoo.patch
@@ -0,0 +1,30 @@
+diff --git a/tests/find_test.rb b/tests/find_test.rb
+index 63bc9c7..22df1e2 100644
+--- a/tests/find_test.rb
++++ b/tests/find_test.rb
+@@ -31,8 +31,13 @@ module Tins
+ assert_equal [ @work_dir, file ], find(@work_dir, :show_hidden => true).to_a
+ end
+
+- if RUBY_PLATFORM !~ /java/
+- def test_check_directory_without_access
++ def test_check_directory_without_access
++ # do not run this test on JRuby
++ omit_if(RUBY_PLATFORM =~ /java/, "Can't run the test on JRuby")
++ # do not run this test if we're root, as it will fail.
++ omit_if(Process::UID.eid == 0, "Can't run the test as root")
++
++ begin
+ mkdir_p directory1 = File.join(@work_dir, 'foo')
+ mkdir_p directory2 = File.join(directory1, 'bar')
+ touch file = File.join(directory2, 'file')
+diff --git a/tests/test_helper.rb b/tests/test_helper.rb
+index e56071a..fbb1635 100644
+--- a/tests/test_helper.rb
++++ b/tests/test_helper.rb
+@@ -4,4 +4,5 @@ if ENV['START_SIMPLECOV'].to_i == 1
+ add_filter "#{File.basename(File.dirname(__FILE__))}/"
+ end
+ end
++gem 'test-unit', '~> 2.4'
+ require 'test/unit'
diff --git a/dev-ruby/tins/tins-0.4.3.ebuild b/dev-ruby/tins/tins-0.4.3.ebuild
new file mode 100644
index 000000000000..1456ed9a46f1
--- /dev/null
+++ b/dev-ruby/tins/tins-0.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.4.3.ebuild,v 1.1 2012/07/08 12:44:55 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library."
+HOMEPAGE="http://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 ) "
+
+RUBY_PATCHES=( "${P}-gentoo.patch" )
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}