summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-20 10:46:38 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-20 10:46:38 +0000
commit490ae27ddf2a8dbe7c59fbb723e525d096cab5ce (patch)
tree7909750c65b1dec424b7b3a198017dc4c653a051 /dev-ruby/yard
parentMarked ~ppc wrt #341449. Thansk to hiyuh <hiyuh.root@gmail.com> for report an... (diff)
downloadgentoo-2-490ae27ddf2a8dbe7c59fbb723e525d096cab5ce.tar.gz
gentoo-2-490ae27ddf2a8dbe7c59fbb723e525d096cab5ce.tar.bz2
gentoo-2-490ae27ddf2a8dbe7c59fbb723e525d096cab5ce.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/yard')
-rw-r--r--dev-ruby/yard/ChangeLog10
-rw-r--r--dev-ruby/yard/files/yard-0.6.4-config-file-feature.patch19
-rw-r--r--dev-ruby/yard/files/yard-0.6.4-yaml.patch30
-rw-r--r--dev-ruby/yard/yard-0.6.4.ebuild30
4 files changed, 87 insertions, 2 deletions
diff --git a/dev-ruby/yard/ChangeLog b/dev-ruby/yard/ChangeLog
index 135be5f10e9f..e8ad305124f2 100644
--- a/dev-ruby/yard/ChangeLog
+++ b/dev-ruby/yard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/yard
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.11 2010/10/09 07:37:46 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/ChangeLog,v 1.12 2011/02/20 10:46:38 graaff Exp $
+
+*yard-0.6.4 (20 Feb 2011)
+
+ 20 Feb 2011; Hans de Graaff <graaff@gentoo.org> +yard-0.6.4.ebuild,
+ +files/yard-0.6.4-config-file-feature.patch, +files/yard-0.6.4-yaml.patch:
+ Version bump.
09 Oct 2010; Hans de Graaff <graaff@gentoo.org> -yard-0.5.8.ebuild:
Remove old version.
diff --git a/dev-ruby/yard/files/yard-0.6.4-config-file-feature.patch b/dev-ruby/yard/files/yard-0.6.4-config-file-feature.patch
new file mode 100644
index 000000000000..df2c5d92bdac
--- /dev/null
+++ b/dev-ruby/yard/files/yard-0.6.4-config-file-feature.patch
@@ -0,0 +1,19 @@
+commit e1cafe5d2123631cdff8c115de15575bc6643677
+Author: Loren Segal <lsegal@soen.ca>
+Date: Sun Jan 23 04:05:41 2011 -0500
+
+ Fix failing spec when ~/.yard/ignored_plugins does not exist
+
+diff --git a/spec/config_spec.rb b/spec/config_spec.rb
+index 8aea427..5bcaa60 100644
+--- a/spec/config_spec.rb
++++ b/spec/config_spec.rb
+@@ -17,7 +17,7 @@ describe YARD::Config do
+
+ it "should overwrite options with data in ~/.yard/config" do
+ File.should_receive(:file?).with(YARD::Config::CONFIG_FILE).and_return(true)
+- File.should_receive(:file?).with(YARD::Config::IGNORED_PLUGINS).and_return(true)
++ File.should_receive(:file?).with(YARD::Config::IGNORED_PLUGINS).and_return(false)
+ YAML.should_receive(:load_file).with(YARD::Config::CONFIG_FILE).and_return({'test' => true})
+ YARD::Config.load
+ YARD::Config.options[:test].should be_true
diff --git a/dev-ruby/yard/files/yard-0.6.4-yaml.patch b/dev-ruby/yard/files/yard-0.6.4-yaml.patch
new file mode 100644
index 000000000000..2bdf8ef7ee01
--- /dev/null
+++ b/dev-ruby/yard/files/yard-0.6.4-yaml.patch
@@ -0,0 +1,30 @@
+commit 5557352a7793975bcaedf5f18b4e2c2883245f5b
+Author: Akzhan Abdulin <akzhan.abdulin@gmail.com>
+Date: Mon Jan 17 22:20:47 2011 +0300
+
+ Fix uninitialized constant RSpec::Core::ExampleGroup::Nested_2::Nested_1::YAML error
+
+diff --git a/spec/cli/config_spec.rb b/spec/cli/config_spec.rb
+index 1ad52f4..4a5288e 100644
+--- a/spec/cli/config_spec.rb
++++ b/spec/cli/config_spec.rb
+@@ -1,5 +1,7 @@
+ require File.dirname(__FILE__) + '/../spec_helper'
+
++require 'yaml'
++
+ describe YARD::CLI::Config do
+ before do
+ @config = YARD::CLI::Config.new
+diff --git a/spec/config_spec.rb b/spec/config_spec.rb
+index 6e578fc..316d7b8 100644
+--- a/spec/config_spec.rb
++++ b/spec/config_spec.rb
+@@ -1,5 +1,7 @@
+ require File.join(File.dirname(__FILE__), "spec_helper")
+
++require 'yaml'
++
+ describe YARD::Config do
+ describe '.load' do
+ before do
diff --git a/dev-ruby/yard/yard-0.6.4.ebuild b/dev-ruby/yard/yard-0.6.4.ebuild
new file mode 100644
index 000000000000..4de9098d4d94
--- /dev/null
+++ b/dev-ruby/yard/yard-0.6.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/yard/yard-0.6.4.ebuild,v 1.1 2011/02/20 10:46:38 graaff Exp $
+
+EAPI=2
+
+# jruby → fails tests: http://github.com/lsegal/yard/issues/issue/185
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="specs"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_EXTRADOC="README.md ChangeLog"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="templates"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Documentation generation tool for the Ruby programming language"
+HOMEPAGE="http://yardoc.org/"
+
+LICENSE="as-is" # truly
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_PATCHES=( "${FILESDIR}/${P}-yaml.patch" "${FILESDIR}/${P}-config-file-feature.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/redcloth )"