summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-13 06:15:07 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-13 06:15:07 +0000
commit3641edb939dcb331125d165aa4325c07a51044b3 (patch)
tree9687c0ebdb4f01d9e98e247556f1d5040baef28e /dev-ruby/zentest/zentest-4.9.3.ebuild
parentMigrate to python-single-r1 (fixes bug #413753), remove old. (diff)
downloadgentoo-2-3641edb939dcb331125d165aa4325c07a51044b3.tar.gz
gentoo-2-3641edb939dcb331125d165aa4325c07a51044b3.tar.bz2
gentoo-2-3641edb939dcb331125d165aa4325c07a51044b3.zip
Version bump. Cleanup old.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/zentest/zentest-4.9.3.ebuild')
-rw-r--r--dev-ruby/zentest/zentest-4.9.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/zentest/zentest-4.9.3.ebuild b/dev-ruby/zentest/zentest-4.9.3.ebuild
new file mode 100644
index 000000000000..44c5c876ad05
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/zentest/zentest-4.9.3.ebuild,v 1.1 2013/08/13 06:15:07 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ZenTest provides tools to support testing: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="http://rubyforge.org/projects/zentest/"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"