summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-29 05:32:43 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-29 05:32:43 +0000
commit01e3745d9dab3ae45990452923e91de4a5b10b79 (patch)
treee89642728f483c05c023ee336080929382bf6f6b /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-01e3745d9dab3ae45990452923e91de4a5b10b79.tar.gz
gentoo-2-01e3745d9dab3ae45990452923e91de4a5b10b79.tar.bz2
gentoo-2-01e3745d9dab3ae45990452923e91de4a5b10b79.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.10.1.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 3ba8bf9bb4af..72c9d63fe92a 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.41 2014/05/26 05:40:57 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.42 2014/05/29 05:32:43 graaff Exp $
+
+*multi_json-1.10.1 (29 May 2014)
+
+ 29 May 2014; Hans de Graaff <graaff@gentoo.org> +multi_json-1.10.1.ebuild:
+ Version bump.
26 May 2014; Manuel Rüger <mrueg@gentoo.org> multi_json-1.8.4.ebuild:
Remove ruby18 target.
diff --git a/dev-ruby/multi_json/multi_json-1.10.1.ebuild b/dev-ruby/multi_json/multi_json-1.10.1.ebuild
new file mode 100644
index 000000000000..bfa995725a7e
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.10.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.10.1.ebuild,v 1.1 2014/05/29 05:32:43 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="yard"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-1.0 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb || die "Unable to remove bundler."
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove specs specific to oj since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' \
+ -e '/Oj does not create symbols on parse/,/^ end/ s:^:#:' \
+ -e '/with Oj.default_settings/,/^ end/ s:^:#:' \
+ -e '/using one-shot parser/,/^ end/ s:^:#:' \
+ spec/multi_json_spec.rb
+
+ # Avoid simplecov which only works with ruby 1.9
+ sed -i -e '/simplecov/d' -e '/SimpleCov.formatter/,/SimpleCov.start/ d' spec/spec_helper.rb || die
+
+ # Remove unpackaged and for our purposes unneeded coveralls
+ sed -i -e '/coveralls/d' spec/spec_helper.rb || die
+
+ # Avoid testing unpackaged adapters
+ rm spec/{gson,jr_jackson,oj}_adapter_spec.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Compiled code is not supported for jruby 1.6
+ rm spec/json_gem_adapter_spec.rb || die
+ # jr_jackson is not supported but needed for the common tests.
+ rm spec/multi_json_spec.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ for t in spec/*_spec.rb; do
+ ${RUBY} -S rspec ${t} || die
+ done
+}