summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-07 08:16:32 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-07 08:16:32 +0000
commit077be484bd50fcfd05ec6f232ee7bc8088934ab6 (patch)
treef81374d216ac226301491243fe3d973fb11a2ac1 /dev-ruby
parentfix insecure runpaths (bug 485510, thanks hasufell) (diff)
downloadgentoo-2-077be484bd50fcfd05ec6f232ee7bc8088934ab6.tar.gz
gentoo-2-077be484bd50fcfd05ec6f232ee7bc8088934ab6.tar.bz2
gentoo-2-077be484bd50fcfd05ec6f232ee7bc8088934ab6.zip
Version bump for Rails 4.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/arel/ChangeLog7
-rw-r--r--dev-ruby/arel/arel-4.0.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/arel/ChangeLog b/dev-ruby/arel/ChangeLog
index b5e7890520a0..d570b8c78930 100644
--- a/dev-ruby/arel/ChangeLog
+++ b/dev-ruby/arel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/arel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/ChangeLog,v 1.32 2013/03/27 13:44:41 moult Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/ChangeLog,v 1.33 2013/10/07 08:16:32 graaff Exp $
+
+*arel-4.0.0 (07 Oct 2013)
+
+ 07 Oct 2013; Hans de Graaff <graaff@gentoo.org> +arel-4.0.0.ebuild:
+ Version bump for Rails 4.
27 Mar 2013; Dion Moult <moult@gentoo.org> -arel-2.0.10-r1.ebuild:
Remove dev-ruby/arel:2.0 due to lack of upstream support
diff --git a/dev-ruby/arel/arel-4.0.0.ebuild b/dev-ruby/arel/arel-4.0.0.ebuild
new file mode 100644
index 000000000000..5f2091a3839b
--- /dev/null
+++ b/dev-ruby/arel/arel-4.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/arel/arel-4.0.0.ebuild,v 1.1 2013/10/07 08:16:32 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.markdown"
+
+# Generating the gemspec from metadata causes a crash in jruby
+RUBY_FAKEGEM_GEMSPEC="arel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Arel is a Relational Algebra for Ruby."
+HOMEPAGE="http://github.com/rails/arel"
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ virtual/ruby-minitest
+ )"
+
+all_ruby_prepare() {
+ # Put the proper version number in the gemspec.
+ sed -i -e "s/ s.version = \".*\"/ s.version = \"${PV}\"/" arel.gemspec || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}