summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-19 09:27:23 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-19 09:27:23 +0000
commit0ae0a15227b45f3f68fb9b09bb90aaceadb758fe (patch)
tree94a7be18df147e41e264a77188f3dbecfbf57127 /dev-ruby
parentAdded pch USE and do not mix CFLAGS/CXXFLAGS (diff)
downloadgentoo-2-0ae0a15227b45f3f68fb9b09bb90aaceadb758fe.tar.gz
gentoo-2-0ae0a15227b45f3f68fb9b09bb90aaceadb758fe.tar.bz2
gentoo-2-0ae0a15227b45f3f68fb9b09bb90aaceadb758fe.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rcov/ChangeLog7
-rw-r--r--dev-ruby/rcov/rcov-0.9.9.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 058b79971e10..66d4c985d8f8 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rcov
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.17 2010/06/29 05:09:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.18 2010/09/19 09:27:23 graaff Exp $
+
+*rcov-0.9.9 (19 Sep 2010)
+
+ 19 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rcov-0.9.9.ebuild:
+ Version bump.
*rcov-0.9.8 (29 Jun 2010)
diff --git a/dev-ruby/rcov/rcov-0.9.9.ebuild b/dev-ruby/rcov/rcov-0.9.9.ebuild
new file mode 100644
index 000000000000..6c037799490a
--- /dev/null
+++ b/dev-ruby/rcov/rcov-0.9.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.9.ebuild,v 1.1 2010/09/19 09:27:23 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
+
+inherit ruby-fakegem versionator eutils
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+#SRC_URI="http://github.com/relevance/${PN}/tarball/release_$(replace_all_version_separators _) -> ${P}.tgz"
+SRC_URI="http://github.com/relevance/${PN}/tarball/4d94640ac1ff79c272c78307437ecccc93fedabe -> ${P}.tgz"
+
+S="${WORKDIR}/relevance-${PN}-*"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+# Tests are currently failing but upstream says it should be fine, I
+# think it's a bug in their code but we'll see.
+RESTRICT=test
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.7.1-jruby.patch
+
+ # Without this change, testing will always cause the extension to
+ # be rebuilt, and we don't want that.
+ sed -i -e '/:test_rcovrt =>/s| => \[.*\]||' Rakefile || die "Rakefile fix failed"
+
+ # remove pre-packaged jar file (d'oh!)
+ rm lib/rcovrt.jar || die
+}
+
+each_ruby_compile() {
+ if [[ $(basename ${RUBY}) = "jruby" ]]; then
+ ${RUBY} -S rake lib/rcovrt.jar || die "build failed"
+ else
+ ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/rcovrt/rcovrt.so lib/rcovrt.so
+ fi
+}