summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-02 20:02:07 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-02 20:02:07 +0000
commit14a87141d71675bc98740b2e3ad8253e9f690e3c (patch)
tree90127d79c3722c72be2ee25c8a81c73a11360f29 /dev-ruby
parentold (diff)
downloadgentoo-2-14a87141d71675bc98740b2e3ad8253e9f690e3c.tar.gz
gentoo-2-14a87141d71675bc98740b2e3ad8253e9f690e3c.tar.bz2
gentoo-2-14a87141d71675bc98740b2e3ad8253e9f690e3c.zip
Install the header file as part of the gem package.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rcairo/ChangeLog8
-rw-r--r--dev-ruby/rcairo/rcairo-1.10.0-r2.ebuild (renamed from dev-ruby/rcairo/rcairo-1.10.0-r1.ebuild)15
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-ruby/rcairo/ChangeLog b/dev-ruby/rcairo/ChangeLog
index 6a73ce200218..e578595e103e 100644
--- a/dev-ruby/rcairo/ChangeLog
+++ b/dev-ruby/rcairo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rcairo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.49 2011/02/02 19:24:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.50 2011/02/02 20:02:07 graaff Exp $
+
+*rcairo-1.10.0-r2 (02 Feb 2011)
+
+ 02 Feb 2011; Hans de Graaff <graaff@gentoo.org> -rcairo-1.10.0-r1.ebuild,
+ +rcairo-1.10.0-r2.ebuild:
+ Install the header file as part of the gem package.
*rcairo-1.10.0-r1 (02 Feb 2011)
diff --git a/dev-ruby/rcairo/rcairo-1.10.0-r1.ebuild b/dev-ruby/rcairo/rcairo-1.10.0-r2.ebuild
index ced13e840eb3..17c8d9fd2417 100644
--- a/dev-ruby/rcairo/rcairo-1.10.0-r1.ebuild
+++ b/dev-ruby/rcairo/rcairo-1.10.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.0-r1.ebuild,v 1.1 2011/02/02 19:24:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.10.0-r2.ebuild,v 1.1 2011/02/02 20:02:07 graaff Exp $
EAPI=2
@@ -20,7 +20,9 @@ RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="AUTHORS NEWS"
-inherit multilib ruby-ng ruby-fakegem
+RUBY_FAKEGEM_EXTRAINSTALL="src"
+
+inherit multilib ruby-fakegem
DESCRIPTION="Ruby bindings for cairo"
HOMEPAGE="http://cairographics.org/rcairo/"
@@ -59,6 +61,8 @@ each_ruby_compile() {
# again, try to make it more standard, to install it more easily.
cp ext/cairo/cairo$(get_modname) lib/ || die
+ mkdir src || die
+ cp ext/cairo/rb_cairo.h src/ || die
}
each_ruby_test() {
@@ -68,13 +72,6 @@ each_ruby_test() {
-e 'gem "test-unit"; require "test/unit"; Dir.glob("test/**/test_*.rb") {|f| load f}' || die "tests failed"
}
-each_ruby_install() {
- each_fakegem_install
-
- insinto $(ruby_get_hdrdir)
- doins ext/cairo/rb_cairo.h || die "Cannot install header file."
-}
-
all_ruby_install() {
all_fakegem_install