summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-10-03 05:03:15 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-10-03 05:03:15 +0000
commit1e1b592bad26c5f81e176cf852fd0027eb68cf08 (patch)
treea502d86e40e919a81f07e1f66f4c204c44f0a401 /dev-ruby
parentforce installing with -j1 #149901 (diff)
downloadgentoo-2-1e1b592bad26c5f81e176cf852fd0027eb68cf08.tar.gz
gentoo-2-1e1b592bad26c5f81e176cf852fd0027eb68cf08.tar.bz2
gentoo-2-1e1b592bad26c5f81e176cf852fd0027eb68cf08.zip
Added 0.2.2 together with a patch to fix #148657
(Portage version: 2.1.1)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-zoom/ChangeLog8
-rw-r--r--dev-ruby/ruby-zoom/files/0.2.0-ldflags.patch11
-rw-r--r--dev-ruby/ruby-zoom/files/digest-ruby-zoom-0.2.23
-rw-r--r--dev-ruby/ruby-zoom/ruby-zoom-0.2.2.ebuild21
4 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/ruby-zoom/ChangeLog b/dev-ruby/ruby-zoom/ChangeLog
index a2a4c5002a5e..de0361cc0ee6 100644
--- a/dev-ruby/ruby-zoom/ChangeLog
+++ b/dev-ruby/ruby-zoom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-zoom
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-zoom/ChangeLog,v 1.5 2006/04/27 19:25:26 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-zoom/ChangeLog,v 1.6 2006/10/03 05:03:15 pclouds Exp $
+
+*ruby-zoom-0.2.2 (03 Oct 2006)
+
+ 03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ +files/0.2.0-ldflags.patch, +ruby-zoom-0.2.2.ebuild:
+ Added 0.2.2 together with a patch to fix #148657
27 Apr 2006; Marien Zwart <marienz@gentoo.org>
files/digest-ruby-zoom-0.2.0, Manifest:
diff --git a/dev-ruby/ruby-zoom/files/0.2.0-ldflags.patch b/dev-ruby/ruby-zoom/files/0.2.0-ldflags.patch
new file mode 100644
index 000000000000..56c90419c0ee
--- /dev/null
+++ b/dev-ruby/ruby-zoom/files/0.2.0-ldflags.patch
@@ -0,0 +1,11 @@
+diff -ur ruby-zoom-0.2.0/extconf.rb ruby-zoom-0.2.0.new/extconf.rb
+--- ruby-zoom-0.2.0/extconf.rb 2005-08-17 04:00:27.000000000 +0700
++++ ruby-zoom-0.2.0.new/extconf.rb 2006-10-02 20:29:15.000000000 +0700
+@@ -9,6 +9,6 @@
+ err "Yaz ZOOM header not available" unless have_header("yaz/zoom.h")
+
+ $CFLAGS << " #{`yaz-config --cflags`} "
+-$LDFLAGS << " #{`yaz-config --libs`} "
++$libs += " #{`yaz-config --libs`.chomp} "
+
+ create_makefile("zoom", "src")
diff --git a/dev-ruby/ruby-zoom/files/digest-ruby-zoom-0.2.2 b/dev-ruby/ruby-zoom/files/digest-ruby-zoom-0.2.2
new file mode 100644
index 000000000000..38c267ae541a
--- /dev/null
+++ b/dev-ruby/ruby-zoom/files/digest-ruby-zoom-0.2.2
@@ -0,0 +1,3 @@
+MD5 e38f664296b70b2d74962359f381cfb7 ruby-zoom-0.2.2.tar.gz 25381
+RMD160 3c9bf7977480a1ef55fd0140ce2f062fbc4d60b2 ruby-zoom-0.2.2.tar.gz 25381
+SHA256 18f22c3770df73d8dc97a71d9974a2087ef4947e1b640cb0c91c569f00db5db1 ruby-zoom-0.2.2.tar.gz 25381
diff --git a/dev-ruby/ruby-zoom/ruby-zoom-0.2.2.ebuild b/dev-ruby/ruby-zoom/ruby-zoom-0.2.2.ebuild
new file mode 100644
index 000000000000..1f6d3bc250eb
--- /dev/null
+++ b/dev-ruby/ruby-zoom/ruby-zoom-0.2.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-zoom/ruby-zoom-0.2.2.ebuild,v 1.1 2006/10/03 05:03:15 pclouds Exp $
+
+inherit ruby
+
+IUSE=""
+
+DESCRIPTION="A Ruby binding to the Z39.50 Object-Orientation Model (ZOOM)"
+HOMEPAGE="http://ruby-zoom.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/6940/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+DEPEND="virtual/ruby
+ dev-libs/yaz"
+
+USE_RUBY="ruby18"
+PATCHES="${FILESDIR}/0.2.0-ldflags.patch"