summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2007-01-06 17:07:17 +0000
committerHans de Graaff <graaff@gentoo.org>2007-01-06 17:07:17 +0000
commit38a77f530173a58c55935189fc4eea7312d798fa (patch)
treeb68a6035738730db6512357d2a0fe25668d02fb4 /dev-ruby
parentAdd ~alpha keyword. (diff)
downloadgentoo-2-38a77f530173a58c55935189fc4eea7312d798fa.tar.gz
gentoo-2-38a77f530173a58c55935189fc4eea7312d798fa.tar.bz2
gentoo-2-38a77f530173a58c55935189fc4eea7312d798fa.zip
Add doc USE flag, fixing #159833 and #160042
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog9
-rw-r--r--dev-ruby/rmagick/files/digest-rmagick-1.14.1-r13
-rw-r--r--dev-ruby/rmagick/rmagick-1.14.1-r1.ebuild63
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 91082580bb74..7d529deb51bd 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.30 2007/01/03 08:52:21 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.31 2007/01/06 17:07:17 graaff Exp $
+
+*rmagick-1.14.1-r1 (06 Jan 2007)
+
+ 06 Jan 2007; Hans de Graaff <graaff@gentoo.org> -rmagick-1.7.3.ebuild,
+ +rmagick-1.14.1-r1.ebuild:
+ Add doc USE flag and allow the examples that are part of the documentation to
+ fail. Fixes #159833 and #160042. Remove old version.
03 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
rmagick-1.14.1.ebuild:
diff --git a/dev-ruby/rmagick/files/digest-rmagick-1.14.1-r1 b/dev-ruby/rmagick/files/digest-rmagick-1.14.1-r1
new file mode 100644
index 000000000000..223578db542d
--- /dev/null
+++ b/dev-ruby/rmagick/files/digest-rmagick-1.14.1-r1
@@ -0,0 +1,3 @@
+MD5 7e92ac388252a7c5de817ce19af94d8d RMagick-1.14.1.tar.bz2 953136
+RMD160 7c739e969b39d33c02103c22aea2a721b56d0269 RMagick-1.14.1.tar.bz2 953136
+SHA256 a8bbfdd398a700fec780525e3720b0d61e48f3a645684100e407e7d15b74a443 RMagick-1.14.1.tar.bz2 953136
diff --git a/dev-ruby/rmagick/rmagick-1.14.1-r1.ebuild b/dev-ruby/rmagick/rmagick-1.14.1-r1.ebuild
new file mode 100644
index 000000000000..6d30dafcb26b
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-1.14.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-1.14.1-r1.ebuild,v 1.1 2007/01/06 17:07:17 graaff Exp $
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/14052/RMagick-${PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc"
+DEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.0"
+
+S=${WORKDIR}/RMagick-${PV}
+
+# Using a custom src_compile instead of the ruby one because the ruby
+# one gets confused by an additional setup.rb that should not be used
+# here.
+src_compile() {
+ myconf="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ myconf="${myconf} --disable-htmldoc --enable-allow-example-errors"
+ fi
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-ruby=${RUBY} \
+ ${myconf} \
+ "$@" || die "econf failed"
+
+ ruby_emake "$@" || die
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} setup.rb config --prefix=${D}/usr "$@" \
+ ${RUBY_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix=${D} "$@" \
+ ${RUBY_ECONF} || die "setup.rb install failed"
+}