summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-09 05:15:49 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-09 05:15:49 +0000
commit8e1b46d0e644f5c711105414f86683f461ca6ef8 (patch)
tree4c80855876eeeaf5646e5dca9fbe9db91e18d1dc /dev-ruby
parentCleanup. (diff)
downloadgentoo-2-8e1b46d0e644f5c711105414f86683f461ca6ef8.tar.gz
gentoo-2-8e1b46d0e644f5c711105414f86683f461ca6ef8.tar.bz2
gentoo-2-8e1b46d0e644f5c711105414f86683f461ca6ef8.zip
Initial import for Rails 4. This code was extracted into a separate package from Rails 3. It is also a dependency for dev-ruby/fast_gettext.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/protected_attributes/ChangeLog11
-rw-r--r--dev-ruby/protected_attributes/metadata.xml5
-rw-r--r--dev-ruby/protected_attributes/protected_attributes-1.0.3.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/protected_attributes/ChangeLog b/dev-ruby/protected_attributes/ChangeLog
new file mode 100644
index 000000000000..04f305fd63b8
--- /dev/null
+++ b/dev-ruby/protected_attributes/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ruby/protected_attributes
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/ChangeLog,v 1.1 2013/10/09 05:15:49 graaff Exp $
+
+*protected_attributes-1.0.3 (09 Oct 2013)
+
+ 09 Oct 2013; Hans de Graaff <graaff@gentoo.org>
+ +protected_attributes-1.0.3.ebuild, +metadata.xml:
+ Initial import for Rails 4. This code was extracted into a separate package
+ from Rails 3. It is also a dependency for dev-ruby/fast_gettext.
+
diff --git a/dev-ruby/protected_attributes/metadata.xml b/dev-ruby/protected_attributes/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/protected_attributes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/protected_attributes/protected_attributes-1.0.3.ebuild b/dev-ruby/protected_attributes/protected_attributes-1.0.3.ebuild
new file mode 100644
index 000000000000..5bd368ba6227
--- /dev/null
+++ b/dev-ruby/protected_attributes/protected_attributes-1.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/protected_attributes/protected_attributes-1.0.3.ebuild,v 1.1 2013/10/09 05:15:49 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protect attributes from mass-assignment in ActiveRecord models"
+HOMEPAGE="https://github.com/rails/protected_attributes"
+SRC_URI="https://github.com/rails/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="1"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ =dev-ruby/activemodel-4*
+"
+
+ruby_add_bdepend "test? (
+ =dev-ruby/actionpack-4*
+ =dev-ruby/activerecord-4*
+ dev-ruby/mocha
+ dev-ruby/sqlite3
+)"