summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-04 09:36:31 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-04 09:36:31 +0000
commit971ac9f8e72d2612b2d072856ddb7304ad0a0d65 (patch)
tree122a41f873f6a34da9c7a5b72895a56ee319e3c9 /dev-ruby
parentVersion bump for Rails 3.0.9. (diff)
downloadgentoo-2-971ac9f8e72d2612b2d072856ddb7304ad0a0d65.tar.gz
gentoo-2-971ac9f8e72d2612b2d072856ddb7304ad0a0d65.tar.bz2
gentoo-2-971ac9f8e72d2612b2d072856ddb7304ad0a0d65.zip
Version bump for Rails 3.0.9.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog11
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.7.ebuild4
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.9.ebuild61
3 files changed, 73 insertions, 3 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 6fb89ec0bae4..a4d32aa96898 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.157 2011/06/09 17:09:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.158 2011/07/04 09:36:31 graaff Exp $
+
+*activerecord-3.0.9 (04 Jul 2011)
+
+ 04 Jul 2011; Hans de Graaff <graaff@gentoo.org> activerecord-3.0.7.ebuild,
+ +activerecord-3.0.9.ebuild:
+ Version bump for Rails 3.0.9.
+
+ 18 Jun 2011; Hans de Graaff <graaff@gentoo.org> activerecord-3.0.7.ebuild:
+ Depend on the right slot for arel, fixes bug 372047.
*activerecord-2.3.12 (09 Jun 2011)
diff --git a/dev-ruby/activerecord/activerecord-3.0.7.ebuild b/dev-ruby/activerecord/activerecord-3.0.7.ebuild
index cc40eb52fd69..8bc98d2c97ab 100644
--- a/dev-ruby/activerecord/activerecord-3.0.7.ebuild
+++ b/dev-ruby/activerecord/activerecord-3.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.7.ebuild,v 1.3 2011/06/08 18:48:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.7.ebuild,v 1.4 2011/07/04 09:36:31 graaff Exp $
EAPI=2
USE_RUBY="ruby18 ree18"
@@ -28,7 +28,7 @@ S="${WORKDIR}/rails-rails-*/activerecord"
ruby_add_rdepend "~dev-ruby/activesupport-${PV}
~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.2
+ >=dev-ruby/arel-2.0.2:2.0
>=dev-ruby/tzinfo-0.3.23
sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
mysql? ( dev-ruby/mysql2:0.2 )
diff --git a/dev-ruby/activerecord/activerecord-3.0.9.ebuild b/dev-ruby/activerecord/activerecord-3.0.9.ebuild
new file mode 100644
index 000000000000..515aac3b42cc
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.0.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.9.ebuild,v 1.1 2011/07/04 09:36:31 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+S="${WORKDIR}/rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-2.0.10-r1:2.0
+ >=dev-ruby/tzinfo-0.3.23
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
+ mysql? ( dev-ruby/mysql2:0.2 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.3
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}