summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-06-23 07:36:45 +0000
committerHans de Graaff <graaff@gentoo.org>2013-06-23 07:36:45 +0000
commitaae3b533bda6985dd63392e9cc98a34312dda766 (patch)
tree80d8aca72f9b5d2ca9bbb029908a2127c40c7047 /dev-ruby
parentFix for bug #450742 - Newer versions of curl are incompatible with zabbix 2.0... (diff)
downloadgentoo-2-aae3b533bda6985dd63392e9cc98a34312dda766.tar.gz
gentoo-2-aae3b533bda6985dd63392e9cc98a34312dda766.tar.bz2
gentoo-2-aae3b533bda6985dd63392e9cc98a34312dda766.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/treetop/ChangeLog7
-rw-r--r--dev-ruby/treetop/treetop-1.4.14.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index ccbb3b6a73fb..f6504bf892e5 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.41 2013/01/16 00:15:13 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.42 2013/06/23 07:36:45 graaff Exp $
+
+*treetop-1.4.14 (23 Jun 2013)
+
+ 23 Jun 2013; Hans de Graaff <graaff@gentoo.org> +treetop-1.4.14.ebuild:
+ Version bump.
16 Jan 2013; Rick Farina <zerochaos@gentoo.org> treetop-1.4.10-r1.ebuild,
treetop-1.4.10.ebuild:
diff --git a/dev-ruby/treetop/treetop-1.4.14.ebuild b/dev-ruby/treetop/treetop-1.4.14.ebuild
new file mode 100644
index 000000000000..d37e63bf7145
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.14.ebuild,v 1.1 2013/06/23 07:36:45 graaff Exp $
+
+EAPI=5
+
+# jruby fails tests, not investigated yet.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-0.10.2 dev-ruby/activesupport )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_prepare() {
+ # Use a ruby18 compatible regexp, already fixed upstream.
+ sed -i -e 's/\[:\^space:\]/\^[:space:]/' spec/compiler/character_class_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+}