summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-28 17:41:51 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-28 17:41:51 +0000
commitc4c87d11701abf0572ca644d1f059e2596a6fb68 (patch)
tree97e2e8013298ec6e2677dca123ac41b6cc837055 /dev-ruby
parentNo need for eutils. (diff)
downloadgentoo-2-c4c87d11701abf0572ca644d1f059e2596a6fb68.tar.gz
gentoo-2-c4c87d11701abf0572ca644d1f059e2596a6fb68.tar.bz2
gentoo-2-c4c87d11701abf0572ca644d1f059e2596a6fb68.zip
Comment out test relying on specific DNS results, bug 395155.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/httpclient/ChangeLog5
-rw-r--r--dev-ruby/httpclient/httpclient-2.2.2.ebuild12
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 1c51474a0d95..a7cc73cab801 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.34 2012/04/28 17:34:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.35 2012/04/28 17:41:51 graaff Exp $
+
+ 28 Apr 2012; Hans de Graaff <graaff@gentoo.org> httpclient-2.2.2.ebuild:
+ Comment out test relying on specific DNS results, bug 395155.
28 Apr 2012; Hans de Graaff <graaff@gentoo.org> httpclient-2.2.2.ebuild:
Comment out harmless test failures, bug 411191.
diff --git a/dev-ruby/httpclient/httpclient-2.2.2.ebuild b/dev-ruby/httpclient/httpclient-2.2.2.ebuild
index 1ed9bf3dfa6e..6fbf3c5897e8 100644
--- a/dev-ruby/httpclient/httpclient-2.2.2.ebuild
+++ b/dev-ruby/httpclient/httpclient-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.2.2.ebuild,v 1.5 2012/04/28 17:34:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.2.2.ebuild,v 1.6 2012/04/28 17:41:51 graaff Exp $
EAPI=4
@@ -36,6 +36,13 @@ ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
all_ruby_prepare () {
rm Gemfile || die
sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Comment out harmless test failures with ruby 1.8, bug 411191
+ sed -i -e '228,268 s:^:#:' test/test_http-access2.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
}
each_ruby_prepare() {
@@ -51,9 +58,6 @@ each_ruby_prepare() {
*)
;;
esac
-
- # Comment out harmless test failures with ruby 1.8, bug 411191
- sed -i -e '228,268 s:^:#:' test/test_http-access2.rb || die
}
each_ruby_test() {