summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-05-15 05:47:40 +0000
committerHans de Graaff <graaff@gentoo.org>2009-05-15 05:47:40 +0000
commitcefbef0b40d9ba70714f581b971afa3455ef533c (patch)
treef105a8eea3e9aa5ea9187a62ec6ea6a86d0e1a02 /dev-ruby
parentFix building with GCC 4.4. Thanks to Kent Fredric for the patch. (bug (diff)
downloadgentoo-2-cefbef0b40d9ba70714f581b971afa3455ef533c.tar.gz
gentoo-2-cefbef0b40d9ba70714f581b971afa3455ef533c.tar.bz2
gentoo-2-cefbef0b40d9ba70714f581b971afa3455ef533c.zip
Version bump.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/rmagick-2.9.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 54af8e3aa44c..8a8cfe81fbd8 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.142 2009/03/18 14:58:16 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.143 2009/05/15 05:47:40 graaff Exp $
+
+*rmagick-2.9.2 (15 May 2009)
+
+ 15 May 2009; Hans de Graaff <graaff@gentoo.org> +rmagick-2.9.2.ebuild:
+ Version bump supporting functionality in newer versions of ImageMagick.
18 Mar 2009; Brent Baude <ranger@gentoo.org> rmagick-2.9.0.ebuild:
stable ppc, bug 260601
diff --git a/dev-ruby/rmagick/rmagick-2.9.2.ebuild b/dev-ruby/rmagick/rmagick-2.9.2.ebuild
new file mode 100644
index 000000000000..9a4679c273e5
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.9.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.9.2.ebuild,v 1.1 2009/05/15 05:47:40 graaff Exp $
+
+EAPI="2"
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="mirror://rubyforge/rmagick/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+RDEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.6[-hdri]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/ghostscript media-libs/libwmf )"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+# Use a custom src_compile because the setup.rb included with RMagick
+# doesn't like extra parameters during the setup phase.
+src_compile() {
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+src_install() {
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" \
+ --doc-dir="${D}/usr/share/doc/${P}/html" "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
+
+ use examples && dodoc examples/*
+}