summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-09 01:58:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-09 01:58:47 +0000
commitd072b914c4311fbbb73a7a2562aae94bd64615e3 (patch)
tree8e67950c62365ef38e59d95a71bbcf091452a15a /dev-ruby
parentAdd ruby20 target. (diff)
downloadgentoo-2-d072b914c4311fbbb73a7a2562aae94bd64615e3.tar.gz
gentoo-2-d072b914c4311fbbb73a7a2562aae94bd64615e3.tar.bz2
gentoo-2-d072b914c4311fbbb73a7a2562aae94bd64615e3.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/chunky_png/ChangeLog7
-rw-r--r--dev-ruby/chunky_png/chunky_png-1.2.8-r1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/chunky_png/ChangeLog b/dev-ruby/chunky_png/ChangeLog
index 406a9f4733f6..9412421aa45f 100644
--- a/dev-ruby/chunky_png/ChangeLog
+++ b/dev-ruby/chunky_png/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/chunky_png
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/chunky_png/ChangeLog,v 1.8 2013/09/04 23:59:34 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/chunky_png/ChangeLog,v 1.9 2013/10/09 01:58:47 mrueg Exp $
+
+*chunky_png-1.2.8-r1 (09 Oct 2013)
+
+ 09 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +chunky_png-1.2.8-r1.ebuild:
+ Add ruby20 target.
04 Sep 2013; Manuel Rüger <mrueg@gentoo.org> -chunky_png-1.2.6.ebuild,
-chunky_png-1.2.7.ebuild:
diff --git a/dev-ruby/chunky_png/chunky_png-1.2.8-r1.ebuild b/dev-ruby/chunky_png/chunky_png-1.2.8-r1.ebuild
new file mode 100644
index 000000000000..6328eae1632e
--- /dev/null
+++ b/dev-ruby/chunky_png/chunky_png-1.2.8-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/chunky_png/chunky_png-1.2.8-r1.ebuild,v 1.1 2013/10/09 01:58:47 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="BENCHMARKS.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="chunky_png.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby library that can read and write PNG images"
+HOMEPAGE="http://wiki.github.com/wvanbergen/chunky_png"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' {spec,benchmarks}/*.rb || die
+ rm Gemfile* || die
+}