summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-15 07:51:00 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-15 07:51:00 +0000
commitee6d13409d29c61d594b90ecaecd4946787471b6 (patch)
treee1300d278943662a615bb05ab2d09bbe3367b281 /dev-ruby
parentVersion bump for rails 2.3.10. (diff)
downloadgentoo-2-ee6d13409d29c61d594b90ecaecd4946787471b6.tar.gz
gentoo-2-ee6d13409d29c61d594b90ecaecd4946787471b6.tar.bz2
gentoo-2-ee6d13409d29c61d594b90ecaecd4946787471b6.zip
Version bump for rails 2.3.10.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.10.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 04c128a9d622..a48a60094cd6 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.145 2010/09/29 22:27:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.146 2010/10/15 07:51:00 graaff Exp $
+
+*actionmailer-2.3.10 (15 Oct 2010)
+
+ 15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
+ +actionmailer-2.3.10.ebuild:
+ Version bump for rails 2.3.10.
29 Sep 2010; Brent Baude <ranger@gentoo.org> actionmailer-2.3.8.ebuild:
Marking actionmailer-2.3.8 ~ppc64 for bug 322175
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.10.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.10.ebuild
new file mode 100644
index 000000000000..7fc5e4db55f7
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.10.ebuild,v 1.1 2010/10/15 07:51:00 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}