summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-19 07:07:01 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-19 07:07:01 +0000
commitf1b9322ac71f58ac07654e306be356f6c86268b8 (patch)
tree79814d0e27ad51218d5bba17a45705d0d783d698 /dev-ruby
parentInitial import. Test dependency of markaby 0.7.1 (diff)
downloadgentoo-2-f1b9322ac71f58ac07654e306be356f6c86268b8.tar.gz
gentoo-2-f1b9322ac71f58ac07654e306be356f6c86268b8.tar.bz2
gentoo-2-f1b9322ac71f58ac07654e306be356f6c86268b8.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mini_magick/ChangeLog7
-rw-r--r--dev-ruby/mini_magick/mini_magick-1.3.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
index 52af2e737901..c9d50de520b3 100644
--- a/dev-ruby/mini_magick/ChangeLog
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mini_magick
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.4 2010/08/03 05:49:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.5 2010/09/19 07:07:01 graaff Exp $
+
+*mini_magick-1.3.3 (19 Sep 2010)
+
+ 19 Sep 2010; Hans de Graaff <graaff@gentoo.org> +mini_magick-1.3.3.ebuild:
+ Version bump.
*mini_magick-1.3.2 (03 Aug 2010)
diff --git a/dev-ruby/mini_magick/mini_magick-1.3.3.ebuild b/dev-ruby/mini_magick/mini_magick-1.3.3.ebuild
new file mode 100644
index 000000000000..2bf26ca42aa6
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-1.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-1.3.3.ebuild,v 1.1 2010/09/19 07:07:01 graaff Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+# update: still fails with imagemagick 6.6.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend ">=dev-ruby/subexec-0.0.4"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ # Remove spec definition part because the gemspec file is not included
+ sed -i -e '/gemspec/,$ d' Rakefile || die
+}