summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2013-06-03 09:11:49 +0000
committerMarijn Schouten <hkbst@gentoo.org>2013-06-03 09:11:49 +0000
commit8c8daa73802088e0fc8bf97e9259043a26e106d3 (patch)
treecef9e185fb50b842aa8edcf06c0f54d6ce645295 /dev-scheme/gambit
parentTrivial sync with qt overlay. (diff)
downloadgentoo-2-8c8daa73802088e0fc8bf97e9259043a26e106d3.tar.gz
gentoo-2-8c8daa73802088e0fc8bf97e9259043a26e106d3.tar.bz2
gentoo-2-8c8daa73802088e0fc8bf97e9259043a26e106d3.zip
bump
(Portage version: 2.1.12.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/gambit-4.6.9.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 340990de365b..a7cca0402208 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.38 2013/04/04 07:33:32 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.39 2013/06/03 09:11:49 hkbst Exp $
+
+*gambit-4.6.9 (03 Jun 2013)
+
+ 03 Jun 2013; Marijn Schouten <hkBst@gentoo.org> +gambit-4.6.9.ebuild:
+ bump
*gambit-4.6.7 (04 Apr 2013)
diff --git a/dev-scheme/gambit/gambit-4.6.9.ebuild b/dev-scheme/gambit/gambit-4.6.9.ebuild
new file mode 100644
index 000000000000..9496a989caf2
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.6.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.6.9.ebuild,v 1.1 2013/06/03 09:11:49 hkbst Exp $
+
+EAPI="4"
+
+inherit eutils elisp-common
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND=""
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P} #-devel
+
+IUSE="emacs static"
+
+src_configure() {
+ econf $(use_enable !static shared) --docdir="${EPREFIX}"/usr/share/doc/${PF} --enable-single-host --disable-absolute-shared-libs
+}
+
+src_compile() {
+ emake bootstrap || die
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}