summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-08-26 09:49:52 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-08-26 09:49:52 +0000
commit9b9784d22301095b2237401bc75c79c8c107a77a (patch)
tree1dfc74f3ce5ca7e1ecf6cf69a1ad8f2039df6052 /dev-scheme/gambit
parentFixed unhandled amd64 instruction bug #189396 (valgrind) (diff)
downloadgentoo-2-9b9784d22301095b2237401bc75c79c8c107a77a.tar.gz
gentoo-2-9b9784d22301095b2237401bc75c79c8c107a77a.tar.bz2
gentoo-2-9b9784d22301095b2237401bc75c79c8c107a77a.zip
bump to version 4 final
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/files/digest-gambit-4.0.03
-rw-r--r--dev-scheme/gambit/gambit-4.0.0.ebuild112
3 files changed, 121 insertions, 1 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 78fa05b1efa8..7fc065eec61a 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.9 2007/07/09 13:37:31 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.10 2007/08/26 09:49:51 hkbst Exp $
+
+*gambit-4.0.0 (26 Aug 2007)
+
+ 26 Aug 2007; Marijn Schouten <hkBst@gentoo.org> +gambit-4.0.0.ebuild:
+ bump to version 4 final
09 Jul 2007; Marijn Schouten <hkBst@gentoo.org> gambit-4.0_beta22.ebuild:
add emacs pre- and postlude, bug 184621
diff --git a/dev-scheme/gambit/files/digest-gambit-4.0.0 b/dev-scheme/gambit/files/digest-gambit-4.0.0
new file mode 100644
index 000000000000..afd504bd2775
--- /dev/null
+++ b/dev-scheme/gambit/files/digest-gambit-4.0.0
@@ -0,0 +1,3 @@
+MD5 4421d4e4489713c43626975e7ad3be46 gambc-v4_0_0.tgz 11645990
+RMD160 62f71be66dd6f16a61c92a3e5217a9e41374268d gambc-v4_0_0.tgz 11645990
+SHA256 a4be96da0bb4636e98b8851ea10e0ab284169e8e14613a01e4e5e5fd9bc6a5d2 gambc-v4_0_0.tgz 11645990
diff --git a/dev-scheme/gambit/gambit-4.0.0.ebuild b/dev-scheme/gambit/gambit-4.0.0.ebuild
new file mode 100644
index 000000000000..746c946411ad
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.0.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.1 2007/08/26 09:49:51 hkbst Exp $
+
+inherit eutils elisp-common check-reqs autotools multilib
+
+MY_PN=gambc
+MY_PV=${PV//./_}
+MY_P=${MY_PN}-v${MY_PV}
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v4.0/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="emacs? ( virtual/emacs )"
+
+SITEFILE="50gambit-gentoo.el"
+
+S=${WORKDIR}/${MY_P}
+
+IUSE="emacs big-iron"
+
+pkg_setup() {
+ if ! use big-iron; then
+ ewarn "not using gcc specific optimizations and not compiling syntax-case macro system"
+ ewarn "approximately 0.5GB ram will be needed"
+ ewarn "if you experience thrashing, try disabling parallel building"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="768" check_reqs
+ else
+ ewarn "using gcc specific optimizations and compiling syntax-case macro system"
+ ewarn "this will cause approximately 2GB ram to be used instead of 0.5GB."
+ ewarn "this will cause heavy thrashing of your system unless your system is big iron"
+ # need this much memory in MBytes (does *not* check swap)
+ CHECKREQS_MEMORY="2560" check_reqs
+ fi
+}
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+# cp configure.ac configure.ac.old
+ sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
+ -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
+ eautoreconf
+# diff -u configure.ac.old configure.ac
+}
+
+src_compile() {
+ econf --enable-shared --enable-single-host $(use_enable big-iron)
+ emake || die "emake failed"
+
+ if use emacs; then
+ ( cd misc; elisp-comp *.el )
+ fi
+
+ # compile syntax-case
+ if use big-iron; then
+ einfo "compiling syntax-case.scm..."
+ LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
+ fi
+}
+
+src_test() {
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if ! GAMBCOPT="=." emake -j1 check; then
+ hasq test $FEATURES && die "Make test failed. See above for details."
+ hasq test $FEATURES || eerror "Make test failed. See above for details."
+ fi
+}
+
+src_install() {
+ einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
+
+ rm ${D}/usr/current
+
+ use big-iron && dolib syntax-case.*
+ mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
+
+ # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
+ mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
+
+ # remove emacs/site-lisp/gambit.el
+ rm -r ${D}/usr/share/emacs
+ if use emacs; then
+ elisp-install ${PN} misc/*.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+
+ dodoc INSTALL.txt README
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # create some more explicit names
+ dosym gsc-gambit usr/bin/gambit-compiler
+ dosym gsi usr/bin/gambit-interpreter
+
+ # automatically load syntax-case for r5rs+ goodness
+ dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
+ echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/usr/gambcext
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}