summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:44:02 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-08 02:44:02 +0000
commit0f76ed9b5aca8f5da0098048464667a68bf90895 (patch)
tree37cbdbd95a675a78b59bfe38f1d81244cdaca09d /dev-tcltk/blt
parenttest has no s.. (diff)
downloadgentoo-2-0f76ed9b5aca8f5da0098048464667a68bf90895.tar.gz
gentoo-2-0f76ed9b5aca8f5da0098048464667a68bf90895.tar.bz2
gentoo-2-0f76ed9b5aca8f5da0098048464667a68bf90895.zip
fix bug 259338
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/blt')
-rw-r--r--dev-tcltk/blt/ChangeLog10
-rw-r--r--dev-tcltk/blt/blt-2.4z-r5.ebuild67
-rw-r--r--dev-tcltk/blt/files/pkgIndex.tcl2
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-tcltk/blt/ChangeLog b/dev-tcltk/blt/ChangeLog
index 890c8c865e23..5078eb33c214 100644
--- a/dev-tcltk/blt/ChangeLog
+++ b/dev-tcltk/blt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/blt
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/blt/ChangeLog,v 1.25 2008/10/27 05:26:08 mescalinum Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/blt/ChangeLog,v 1.26 2009/08/08 02:44:02 mescalinum Exp $
+
+*blt-2.4z-r5 (08 Aug 2009)
+
+ 08 Aug 2009; Federico Ferri <mescalinum@gentoo.org> +blt-2.4z-r5.ebuild,
+ +files/pkgIndex.tcl:
+ fix bug 259338
27 Oct 2008; Federico Ferri <mescalinum@gentoo.org>
+files/blt-2.4z-tcl8.5-fixpkgruntime.patch:
diff --git a/dev-tcltk/blt/blt-2.4z-r5.ebuild b/dev-tcltk/blt/blt-2.4z-r5.ebuild
new file mode 100644
index 000000000000..8b3de29860a5
--- /dev/null
+++ b/dev-tcltk/blt/blt-2.4z-r5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/blt/blt-2.4z-r5.ebuild,v 1.1 2009/08/08 02:44:02 mescalinum Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_V_SUFFIX="-8.5.2"
+HOMEPAGE="http://blt.sourceforge.net/
+http://jos.decoster.googlepages.com/bltfortk8.5.2"
+SRC_URI="http://jos.decoster.googlepages.com/${PN}${PV}${MY_V_SUFFIX}.tar.gz"
+DESCRIPTION="BLT is an extension to the Tk toolkit adding new widgets, geometry managers, and misc commands."
+
+IUSE=""
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/tk-8.0
+ x11-libs/libX11"
+
+S="${WORKDIR}/${PN}${PV}${MY_V_SUFFIX}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/blt-2.4z-r4-fix-makefile.patch"
+ epatch "${FILESDIR}/blt-2.4z-r4-fix-makefile2.patch"
+ # From blt-2.4z-6mdk.src.rpm
+ epatch "${FILESDIR}"/blt2.4z-64bit.patch
+
+ #epatch "${FILESDIR}"/blt-2.4z-tcl8.5-fix.patch
+ epatch "${FILESDIR}"/blt-2.4z-tcl8.5-fixpkgruntime.patch
+
+ # Set the correct libdir
+ sed -i -e "s:\(^libdir=\${exec_prefix}/\)lib:\1$(get_libdir):" \
+ configure* || die "sed configure* failed"
+ sed -i -e "/^scriptdir =/s:lib:$(get_libdir):" \
+ Makefile.in demos/Makefile.in || die "sed Makefile.in failed"
+}
+
+src_compile() {
+ # bug 167934
+ append-flags -fPIC
+
+ econf --with-blt=/usr/$(get_libdir) || die "./configure failed"
+ # parallel borks
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin \
+ /usr/$(get_libdir)/blt2.4/demos/bitmaps \
+ /usr/share/man/mann \
+ /usr/include \
+ || die "dodir failed"
+ emake -j1 INSTALL_ROOT="${D}" install || die "make install failed"
+
+ dodoc NEWS PROBLEMS README
+ dohtml html/*.html
+ for f in `ls "${D}"/usr/share/man/mann` ; do
+ mv "${D}"/usr/share/man/mann/${f} "${D}"/usr/share/man/mann/${f/.n/.nblt}
+ done
+
+ # bug 259338 - dev-tcltk/blt-2.4z-r4 provides empty pkgIndex.tcl
+ cp "${FILESDIR}"/pkgIndex.tcl "${D}"/usr/$(get_libdir)/blt2.4/pkgIndex.tcl
+}
diff --git a/dev-tcltk/blt/files/pkgIndex.tcl b/dev-tcltk/blt/files/pkgIndex.tcl
new file mode 100644
index 000000000000..7911d8537b84
--- /dev/null
+++ b/dev-tcltk/blt/files/pkgIndex.tcl
@@ -0,0 +1,2 @@
+package ifneeded BLT 2.4 [list load [file join $dir .. libBLT24.so]]
+package ifneeded BLTlite 2.4 [list load [file join $dir .. libBLTlite24.so]]