summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-08-08 00:10:24 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-08-08 00:10:24 +0000
commit25ebbf3a9d57c27736fe7d969c0a1bd6ca4e7f11 (patch)
treebba5df09d908a9791823fd5b54d73d19e8fda2d8 /dev-tcltk/expect
parentApplied 2.6.31 patch based on 5.10.91.9-r1. (diff)
downloadgentoo-2-25ebbf3a9d57c27736fe7d969c0a1bd6ca4e7f11.tar.gz
gentoo-2-25ebbf3a9d57c27736fe7d969c0a1bd6ca4e7f11.tar.bz2
gentoo-2-25ebbf3a9d57c27736fe7d969c0a1bd6ca4e7f11.zip
fix bug #182278
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/ChangeLog5
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild23
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 6c3c3b97361f..9a157990b114 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.56 2009/06/09 20:11:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.57 2009/08/08 00:10:24 mescalinum Exp $
+
+ 08 Aug 2009; Federico Ferri <mescalinum@gentoo.org> expect-5.43.0.ebuild:
+ fix bug #182278
09 Jun 2009; Alexis Ballier <aballier@gentoo.org> expect-5.43.0.ebuild:
keyword ~x86-fbsd
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index 2279710eca9a..bd6b816b94b3 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.12 2009/06/09 20:11:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.13 2009/08/08 00:10:24 mescalinum Exp $
WANT_AUTOCONF="2.1"
-inherit autotools eutils
+inherit autotools eutils versionator
DESCRIPTION="tool for automating interactive applications"
HOMEPAGE="http://expect.nist.gov/"
@@ -20,19 +20,19 @@ DEPEND=">=dev-lang/tcl-8.2
X? ( >=dev-lang/tk-8.2 )"
RDEPEND="${DEPEND}"
-NON_MICRO_V=${P%.[0-9]}
+NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
S=${WORKDIR}/${NON_MICRO_V}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-multilib.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/"${P}"-multilib.patch
#fix the rpath being set to /var/tmp/portage/...
- epatch ${FILESDIR}/expect-5.39.0-libdir.patch
+ epatch "${FILESDIR}"/expect-5.39.0-libdir.patch
#Removes references to functions that Tcl 8.5 no longer exposes.
- epatch ${FILESDIR}/${P}-avoid-tcl-internals-1.patch
+ epatch "${FILESDIR}"/"${P}"-avoid-tcl-internals-1.patch
sed -i 's#/usr/local/bin#/usr/bin#' expect.man
sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
@@ -88,12 +88,15 @@ src_test() {
src_install() {
dodir /usr/$(get_libdir)
- make install INSTALL_ROOT=${D} || die "make install failed"
+ make install INSTALL_ROOT="${D}" || die "make install failed"
dodoc ChangeLog FAQ HISTORY NEWS README
- local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
+ local lib_basename="lib${NON_MICRO_V/-/}"
+ rm "${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${lib_basename}.a"
+
+ # bug #182278 - /usr/lib/expect.so symlink
+ ln -s "${lib_basename}.so" "${D}/usr/$(get_libdir)/lib${PN}.so"
#install examples if 'doc' is set
if use doc ; then