summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-05-16 23:20:56 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-05-16 23:20:56 +0000
commit53156cca20c1b584dbc983e7dae683ab94b90614 (patch)
tree08089b031ed88cd4fe22c83caca2db32a51baa83 /dev-tcltk/tclpython/tclpython-3.1.ebuild
parentInitial import (Manifest recommit) (diff)
downloadgentoo-2-53156cca20c1b584dbc983e7dae683ab94b90614.tar.gz
gentoo-2-53156cca20c1b584dbc983e7dae683ab94b90614.tar.bz2
gentoo-2-53156cca20c1b584dbc983e7dae683ab94b90614.zip
Initial import
Diffstat (limited to 'dev-tcltk/tclpython/tclpython-3.1.ebuild')
-rw-r--r--dev-tcltk/tclpython/tclpython-3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/tclpython-3.1.ebuild b/dev-tcltk/tclpython/tclpython-3.1.ebuild
new file mode 100644
index 000000000000..77e06a3f085c
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1.ebuild,v 1.1 2004/05/16 23:20:56 matsuu Exp $
+
+inherit distutils
+
+DESCRIPTION="a Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/tcl-8.0
+ >=virtual/python-2.2"
+
+src_compile() {
+ distutils_python_version
+ ${CC} -shared -o tclpython.so.${PV} -s -fPIC ${CFLAGS} -Wall -I/usr/include/python${PYVER} tclpython.c `python-config` -lpthread -lutil || die
+}
+
+src_install() {
+ insinto /usr/lib/tclpython
+ doins tclpython.so.${PV}
+ doins pkgIndex.tcl
+
+ dodoc CHANGES INSTALL README
+ dohtml tclpython.htm
+}