summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-28 00:17:16 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-28 00:17:16 +0000
commit938ef27fe32899edb7ce6e3ca9f0974e58cbdc03 (patch)
tree6fb508a54dc89c0f407d8d7fc5db6f31c7f3a839 /dev-tcltk/tclx
parentcut global scope code #124209 (diff)
downloadgentoo-2-938ef27fe32899edb7ce6e3ca9f0974e58cbdc03.tar.gz
gentoo-2-938ef27fe32899edb7ce6e3ca9f0974e58cbdc03.tar.bz2
gentoo-2-938ef27fe32899edb7ce6e3ca9f0974e58cbdc03.zip
old
Diffstat (limited to 'dev-tcltk/tclx')
-rw-r--r--dev-tcltk/tclx/files/digest-tclx-8.33
-rw-r--r--dev-tcltk/tclx/tclx-8.3.ebuild62
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-tcltk/tclx/files/digest-tclx-8.3 b/dev-tcltk/tclx/files/digest-tclx-8.3
deleted file mode 100644
index cf72236c2977..000000000000
--- a/dev-tcltk/tclx/files/digest-tclx-8.3
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 deb98c29eb8fc1b43cc60198105ce24b tclx8.3.tar.gz 450328
-MD5 e94397490adb2c1c2b1990052b1a92b2 tcl8.3.3.tar.gz 2589894
-MD5 72eb2d4a84f32fc1608e2333f92a2661 tk8.3.3.tar.gz 2537686
diff --git a/dev-tcltk/tclx/tclx-8.3.ebuild b/dev-tcltk/tclx/tclx-8.3.ebuild
deleted file mode 100644
index f34b8bde5b77..000000000000
--- a/dev-tcltk/tclx/tclx-8.3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.17 2006/02/28 00:16:50 vapier Exp $
-
-inherit flag-o-matic eutils
-
-IUSE="X"
-
-DESCRIPTION="A set of extensions to TCL"
-HOMEPAGE="http://www.neosoft.com/TclX/"
-SRC_URI="ftp://ftp.slackware.com/pub/slackware/slackware-8.1/source/tcl/tclx/${PN}${PV}.tar.gz
- ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tcl8.3.3.tar.gz
- ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tk8.3.3.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86 ppc alpha"
-
-DEPEND="=dev-lang/tcl-8.3*
- X? ( =dev-lang/tk-8.3* )"
-
-S=${WORKDIR}/${PN}${PV}
-
-src_unpack() {
- unpack ${A} ; cd ${S}
- epatch ${FILESDIR}/${P}-makecfg.patch
- epatch ${FILESDIR}/${P}-argv.patch
- epatch ${FILESDIR}/${P}-varinit.patch
-}
-
-src_compile() {
- # we have to configure and build tcl before we can do tclx
- cd ${WORKDIR}/tcl8.3.3/unix
- econf || die "econf failed"
- emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
-
- local myconf="--with-tcl=${WORKDIR}/tcl8.3.3/unix --enable-shared"
-
- if use X ; then
- # configure and build tk
- cd ${WORKDIR}/tk8.3.3/unix
- econf || die "econf failed"
- emake CFLAGS="${CFLAGS}" || die
- myconf="${myconf} --with-tk=${WORKDIR}/tk8.3.3/unix"
- else
- myconf="${myconf} --enable-tk=no"
- fi
-
- # configure and build tclx
- cd ${S}/unix
- econf ${myconf} || die "econf failed"
- make CFLAGS="${CFLAGS}" || die
-}
-
-src_install() {
- echo "installing tclx"
- cd ${S}/unix
- make INSTALL_ROOT=${D} install
- cd ${S}
- dodoc CHANGES README TO-DO doc/CONVERSION-NOTES
- doman doc/*.[n3]
-}