summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-31 20:14:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-31 20:14:24 +0000
commit9f0c4ea89e829cbdf12ff0a1d7876467e006be08 (patch)
tree239943e186e1f5a98d100db3d7e651be5bff85c9 /dev-tcltk/tkpiechart
parentx11-libs/pixman-0.17.14 version bump (diff)
downloadgentoo-2-9f0c4ea89e829cbdf12ff0a1d7876467e006be08.tar.gz
gentoo-2-9f0c4ea89e829cbdf12ff0a1d7876467e006be08.tar.bz2
gentoo-2-9f0c4ea89e829cbdf12ff0a1d7876467e006be08.zip
Make it respect multilib and fixed .htm installtion issue per 298194, fixed quoting
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tkpiechart')
-rw-r--r--dev-tcltk/tkpiechart/ChangeLog11
-rw-r--r--dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild27
-rw-r--r--dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild6
3 files changed, 39 insertions, 5 deletions
diff --git a/dev-tcltk/tkpiechart/ChangeLog b/dev-tcltk/tkpiechart/ChangeLog
index 2b96237ed3fc..8b171d720bc7 100644
--- a/dev-tcltk/tkpiechart/ChangeLog
+++ b/dev-tcltk/tkpiechart/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tcltk/tkpiechart
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkpiechart/ChangeLog,v 1.6 2007/02/22 01:34:55 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkpiechart/ChangeLog,v 1.7 2010/03/31 20:14:24 jlec Exp $
+
+*tkpiechart-6.5-r1 (31 Mar 2010)
+
+ 31 Mar 2010; Justin Lecher <jlec@gentoo.org> tkpiechart-6.5.ebuild,
+ +tkpiechart-6.5-r1.ebuild:
+ Make it respect multilib and fixed .htm installtion issue per 298194,
+ fixed quoting
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild b/dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild
new file mode 100644
index 000000000000..19ce62a79621
--- /dev/null
+++ b/dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkpiechart/tkpiechart-6.5-r1.ebuild,v 1.1 2010/03/31 20:14:24 jlec Exp $
+
+inherit multilib
+
+DESCRIPTION="create and update 2D or 3D pie charts in a Tcl/Tk application"
+HOMEPAGE="http://jfontain.free.fr/piechart6.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.3
+ dev-tcltk/tcllib"
+
+src_install() {
+ dodir /usr/$(get_libdir)/tkpiechart
+ ./instapkg.tcl "${D}"/usr/$(get_libdir)/tkpiechart || die
+
+ dodoc CHANGES CONTENTS README TODO || die
+ dohtml *.gif *.htm || die
+ docinto demo
+ dodoc demo* || die
+}
diff --git a/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild b/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild
index a04e7e0980b1..3d5f45c97bb5 100644
--- a/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild
+++ b/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild,v 1.5 2004/11/06 15:38:49 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkpiechart/tkpiechart-6.5.ebuild,v 1.6 2010/03/31 20:14:24 jlec Exp $
DESCRIPTION="create and update 2D or 3D pie charts in a Tcl/Tk application"
HOMEPAGE="http://jfontain.free.fr/piechart6.htm"
@@ -16,7 +16,7 @@ DEPEND=">=dev-lang/tk-8.3
src_install() {
dodir /usr/lib/tkpiechart
- ./instapkg.tcl ${D}/usr/lib/tkpiechart || die
+ ./instapkg.tcl "${D}"/usr/lib/tkpiechart || die
dodoc CHANGES CONTENTS COPYRIGHT INSTALL README TODO
dohtml *.gif *.html