summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-16 09:42:31 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-16 09:42:31 +0000
commitb10aac8233f10fc014164fcd32597760f6dcd179 (patch)
treed73fe707f0baebf6fa0d593ec02cf280cbf23786 /dev-tcltk
parentAdd ~amd64-linux and ~x86-linux keywords (diff)
downloadgentoo-2-b10aac8233f10fc014164fcd32597760f6dcd179.tar.gz
gentoo-2-b10aac8233f10fc014164fcd32597760f6dcd179.tar.bz2
gentoo-2-b10aac8233f10fc014164fcd32597760f6dcd179.zip
dev-tcltk/tix: Straighten Fix for >tcl-8.5
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tix/ChangeLog8
-rw-r--r--dev-tcltk/tix/files/tix-8.4.3-tcl8.5.patch190
-rw-r--r--dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch4
-rw-r--r--dev-tcltk/tix/tix-8.4.3-r1.ebuild61
4 files changed, 260 insertions, 3 deletions
diff --git a/dev-tcltk/tix/ChangeLog b/dev-tcltk/tix/ChangeLog
index e438120666da..8133611ff5a8 100644
--- a/dev-tcltk/tix/ChangeLog
+++ b/dev-tcltk/tix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tix
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.41 2013/01/21 17:18:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.42 2013/05/16 09:42:31 jlec Exp $
+
+*tix-8.4.3-r1 (16 May 2013)
+
+ 16 May 2013; Justin Lecher <jlec@gentoo.org> +tix-8.4.3-r1.ebuild,
+ +files/tix-8.4.3-tcl8.5.patch, files/tix-8.4.3-tcl8.6.patch:
+ Straighten Fix for >tcl-8.5
21 Jan 2013; Justin Lecher <jlec@gentoo.org> tix-8.4.3.ebuild,
+files/tix-8.4.3-tcl8.6.patch:
diff --git a/dev-tcltk/tix/files/tix-8.4.3-tcl8.5.patch b/dev-tcltk/tix/files/tix-8.4.3-tcl8.5.patch
new file mode 100644
index 000000000000..d87cbff7e9a2
--- /dev/null
+++ b/dev-tcltk/tix/files/tix-8.4.3-tcl8.5.patch
@@ -0,0 +1,190 @@
+diff -up Tix8.4.2/generic/tixImgXpm.c_old Tix8.4.2/generic/tixImgXpm.c
+--- Tix8.4.2/generic/tixImgXpm.c_old 2008-01-08 11:53:37.000000000 +0100
++++ Tix8.4.2/generic/tixImgXpm.c 2008-01-08 12:04:49.000000000 +0100
+@@ -45,19 +45,19 @@ static int ImgXpmConfigureMaster _ANSI_
+ int flags));
+ static int ImgXpmGetData _ANSI_ARGS_((Tcl_Interp *interp,
+ PixmapMaster *masterPtr));
+-static char ** ImgXpmGetDataFromFile _ANSI_ARGS_((Tcl_Interp * interp,
++static CONST84 char ** ImgXpmGetDataFromFile _ANSI_ARGS_((Tcl_Interp * interp,
+ char * string, int * numLines_return));
+-static char ** ImgXpmGetDataFromId _ANSI_ARGS_((Tcl_Interp * interp,
++static CONST84 char ** ImgXpmGetDataFromId _ANSI_ARGS_((Tcl_Interp * interp,
+ CONST84 char * id));
+-static char ** ImgXpmGetDataFromString _ANSI_ARGS_((Tcl_Interp*interp,
++static CONST84 char ** ImgXpmGetDataFromString _ANSI_ARGS_((Tcl_Interp*interp,
+ char * string, int * numLines_return));
+ static void ImgXpmGetPixmapFromData _ANSI_ARGS_((
+ Tcl_Interp * interp,
+ PixmapMaster *masterPtr,
+ PixmapInstance *instancePtr));
+-static char * GetType _ANSI_ARGS_((char * colorDefn,
++static CONST84 char * GetType _ANSI_ARGS_((CONST84 char * colorDefn,
+ int * type_ret));
+-static char * GetColor _ANSI_ARGS_((char * colorDefn,
++static CONST84 char * GetColor _ANSI_ARGS_((CONST84 char * colorDefn,
+ char * colorName, int * type_ret));
+
+ /*
+@@ -286,7 +286,7 @@ ImgXpmGetData(interp, masterPtr)
+ Tcl_Interp *interp; /* For reporting errors. */
+ PixmapMaster *masterPtr;
+ {
+- char ** data = NULL;
++ CONST84 char ** data = NULL;
+ int isAllocated = 0; /* do we need to free "data"? */
+ int listArgc;
+ CONST84 char ** listArgv = NULL;
+@@ -363,7 +363,7 @@ ImgXpmGetData(interp, masterPtr)
+ return code;
+ }
+
+-static char ** ImgXpmGetDataFromId(interp, id)
++static CONST84 char ** ImgXpmGetDataFromId(interp, id)
+ Tcl_Interp * interp;
+ CONST84 char * id;
+ {
+@@ -378,13 +378,13 @@ static char ** ImgXpmGetDataFromId(inter
+ if (hashPtr == NULL) {
+ Tcl_AppendResult(interp, "unknown pixmap ID \"", id,
+ "\"", NULL);
+- return (char**)NULL;
++ return NULL;
+ } else {
+- return (char**)Tcl_GetHashValue(hashPtr);
++ return (CONST84 char**)Tcl_GetHashValue(hashPtr);
+ }
+ }
+
+-static char ** ImgXpmGetDataFromString(interp, string, numLines_return)
++static CONST84 char ** ImgXpmGetDataFromString(interp, string, numLines_return)
+ Tcl_Interp * interp;
+ char * string;
+ int * numLines_return;
+@@ -392,7 +392,7 @@ static char ** ImgXpmGetDataFromString(i
+ int quoted;
+ char * p, * list;
+ int numLines;
+- char ** data;
++ CONST84 char ** data;
+
+ /* skip the leading blanks (leading blanks are not defined in the
+ * the XPM definition, but skipping them shouldn't hurt. Also, the ability
+@@ -510,17 +510,17 @@ static char ** ImgXpmGetDataFromString(i
+
+ error:
+ Tcl_AppendResult(interp, "File format error", NULL);
+- return (char**) NULL;
++ return NULL;
+ }
+
+-static char ** ImgXpmGetDataFromFile(interp, fileName, numLines_return)
++static CONST84 char ** ImgXpmGetDataFromFile(interp, fileName, numLines_return)
+ Tcl_Interp * interp;
+ char * fileName;
+ int * numLines_return;
+ {
+ FILE * fd = NULL;
+ int size, n;
+- char ** data;
++ CONST84 char ** data;
+ char *cmdBuffer = NULL;
+ Tcl_DString buffer; /* initialized by Tcl_TildeSubst */
+
+@@ -588,16 +588,16 @@ static char ** ImgXpmGetDataFromFile(int
+ ckfree(cmdBuffer);
+ }
+ Tcl_DStringFree(&buffer);
+- return (char**)NULL;
++ return NULL;
+ }
+
+
+-static char *
++static CONST84 char *
+ GetType(colorDefn, type_ret)
+- char * colorDefn;
++ CONST84 char * colorDefn;
+ int * type_ret;
+ {
+- char * p = colorDefn;
++ CONST84 char * p = colorDefn;
+
+ /* skip white spaces */
+ while (*p && isspace(*p)) {
+@@ -642,9 +642,9 @@ GetType(colorDefn, type_ret)
+ /*
+ * colorName is guaranteed to be big enough
+ */
+-static char *
++static CONST84 char *
+ GetColor(colorDefn, colorName, type_ret)
+- char * colorDefn;
++ CONST84 char * colorDefn;
+ char * colorName; /* if found, name is copied to this array */
+ int * type_ret;
+ {
+@@ -751,7 +751,7 @@ ImgXpmGetPixmapFromData(interp, masterPt
+ }
+
+ for (i=0; i<masterPtr->ncolors; i++) {
+- char * colorDefn; /* the color definition line */
++ CONST84 char * colorDefn; /* the color definition line */
+ char * colorName; /* temp place to hold the color name
+ * defined for one type of visual */
+ char * useName; /* the color name used for this
+@@ -842,7 +842,7 @@ ImgXpmGetPixmapFromData(interp, masterPt
+ * Parse the main body of the image
+ */
+ for (i=0; i<masterPtr->size[1]; i++) {
+- char * p = masterPtr->data[i+lOffset];
++ CONST84 char * p = masterPtr->data[i+lOffset];
+
+ for (j=0; j<masterPtr->size[0]; j++) {
+ if (masterPtr->cpp == 1) {
+diff -up Tix8.4.2/generic/tixImgXpm.h_old Tix8.4.2/generic/tixImgXpm.h
+--- Tix8.4.2/generic/tixImgXpm.h_old 2008-01-08 12:04:59.000000000 +0100
++++ Tix8.4.2/generic/tixImgXpm.h 2008-01-08 12:05:26.000000000 +0100
+@@ -55,7 +55,7 @@ typedef struct PixmapMaster {
+ int size[2]; /* width and height */
+ int ncolors; /* number of colors */
+ int cpp; /* characters per pixel */
+- char ** data; /* The data that defines this pixmap
++ CONST84 char ** data; /* The data that defines this pixmap
+ * image (array of strings). It is
+ * converted into an X Pixmap when this
+ * image is instanciated
+diff -up Tix8.4.2/generic/tixInt.h_old Tix8.4.2/generic/tixInt.h
+--- Tix8.4.2/generic/tixInt.h_old 2008-01-08 12:05:53.000000000 +0100
++++ Tix8.4.2/generic/tixInt.h 2008-01-08 12:09:35.000000000 +0100
+@@ -23,6 +23,10 @@
+ #include <tixPort.h>
+ #endif
+
++#include <stdlib.h>
++#include <string.h>
++#include <ctype.h>
++
+ /*----------------------------------------------------------------------
+ *
+ * Tix Display Item Types
+diff -up Tix8.4.2/Makefile.in_old Tix8.4.2/Makefile.in
+--- Tix8.4.2/Makefile.in_old 2008-01-08 11:43:41.000000000 +0100
++++ Tix8.4.2/Makefile.in 2008-01-08 11:46:22.000000000 +0100
+@@ -128,6 +128,7 @@ SHLIB_LD = @SHLIB_LD@ $(CFLAGS) -Wl,-son
+ SHLIB_LD_FLAGS = @SHLIB_LD_FLAGS@
+ SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
+ STLIB_LD = @STLIB_LD@
++TCL_VERSION = @TCL_VERSION@
+ TCL_DEFS = @TCL_DEFS@
+ TCL_SRC_DIR = @TCL_SRC_DIR@
+ TCL_BIN_DIR = @TCL_BIN_DIR@
+@@ -294,7 +295,7 @@ VPATH = $(srcdir):$(srcdir)/generic:$(sr
+
+ pkgIndex.tcl:
+ (\
+- echo 'if {[catch {package require Tcl 8.4}]} return';\
++ echo 'if {[catch {package require Tcl $(TCL_VERSION)}]} return';\
+ echo 'package ifneeded $(PACKAGE_NAME) $(PACKAGE_VERSION) \
+ [list load [file join $$dir $(PKG_LIB_FILE)] $(PACKAGE_NAME)]'\
+ ) > pkgIndex.tcl
diff --git a/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch b/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch
index 98165a899591..0ed17503a56f 100644
--- a/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch
+++ b/dev-tcltk/tix/files/tix-8.4.3-tcl8.6.patch
@@ -11,8 +11,8 @@ index 7dee30f..26ec054 100644
- order = strtol(sortInterp->result, &end, 0);
- if ((end == sortInterp->result) || (*end != 0)) {
-+ order = strtol(Tcl_GetResult(sortInterp), &end, 0);
-+ if ((end == Tcl_GetResult(sortInterp)) || (*end != 0)) {
++ order = strtol(Tcl_GetStringResult(sortInterp), &end, 0);
++ if ((end == Tcl_GetStringResult(sortInterp)) || (*end != 0)) {
Tcl_ResetResult(sortInterp);
Tcl_AppendResult(sortInterp,
"comparison command returned non-numeric result",
diff --git a/dev-tcltk/tix/tix-8.4.3-r1.ebuild b/dev-tcltk/tix/tix-8.4.3-r1.ebuild
new file mode 100644
index 000000000000..a4e38bfa7bd3
--- /dev/null
+++ b/dev-tcltk/tix/tix-8.4.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.4.3-r1.ebuild,v 1.1 2013/05/16 09:42:31 jlec Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+MY_P="Tix${PV}"
+DESCRIPTION="A widget library for Tcl/Tk"
+HOMEPAGE="http://tix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tix/${MY_P}-src.tar.gz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+RESTRICT="test"
+
+DEPEND="
+ dev-lang/tk
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ (use x86-macos || use x64-macos) || epatch "${FILESDIR}"/${P}-link.patch
+ sed \
+ -e 's:-Os::g' \
+ -i configure tclconfig/tcl.m4 || die
+ epatch \
+ "${FILESDIR}"/${P}-tcl8.5.patch \
+ "${FILESDIR}"/${P}-tcl8.6.patch
+}
+
+src_configure() {
+ econf \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)" \
+ --with-tk="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ default
+
+ # Bug 168897
+ doheader generic/tix.h
+ # Bug 201138
+ if use x86-macos || use x64-macos; then
+ mv "${ED}"/usr/$(get_libdir)/${MY_P}/libTix{,.}${PV}.dylib
+ dosym ${MY_P}/libTix.${PV}.dylib /usr/$(get_libdir)/libTix.${PV}.dylib
+ else
+ dosym ${MY_P}/lib${MY_P}.so /usr/$(get_libdir)/lib${MY_P}.so
+ fi
+
+ dodoc ChangeLog README.txt docs/*.txt
+ dohtml -r index.html ABOUT.html docs/
+}