summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-17 17:06:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-17 17:06:13 +0000
commitd4ca1b7ce8298809587c0c8c4c14d8a49e75159a (patch)
tree44e695ecd7210690f19540c2b4d75034dfb0beda /dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
parentpam_mount: remove old ebuilds (diff)
downloadgentoo-2-d4ca1b7ce8298809587c0c8c4c14d8a49e75159a.tar.gz
gentoo-2-d4ca1b7ce8298809587c0c8c4c14d8a49e75159a.tar.bz2
gentoo-2-d4ca1b7ce8298809587c0c8c4c14d8a49e75159a.zip
fix build with gcc 4.3, bug #227863 and fix tests build
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild')
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
index 8fccb81fd3c3..eabc8c75d955 100644
--- a/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
+++ b/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild,v 1.2 2007/02/06 16:45:54 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/cpp2latex/cpp2latex-2.3-r1.ebuild,v 1.3 2008/06/17 17:06:12 aballier Exp $
inherit eutils
@@ -17,17 +17,15 @@ KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
# neither a compile or runtime dependency
src_unpack() {
- unpack ${A} || die
- cd ${S}/cpp2latex
+ unpack ${A}
+ cd "${S}/cpp2latex"
# bug 44585
- epatch ${FILESDIR}/cpp2latex-2.3.patch || die
-}
-
-src_compile() {
- econf || die
- emake || die
+ epatch "${FILESDIR}/cpp2latex-2.3.patch"
+ # bug #227863
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tests.patch"
}
src_install() {
- make install DESTDIR=${D} || die
+ emake install DESTDIR="${D}" || die "make install failed"
}