summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-16 14:54:51 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-16 14:54:51 +0000
commit351c7fc91529fe3c835d79ea1905836737c9b758 (patch)
tree08342ddfd113f4e29403bc7196699ded20feed2f /dev-tex/html2latex/html2latex-1.1.ebuild
parentUpdate metadata.xml for www-servers herd. (diff)
downloadgentoo-2-351c7fc91529fe3c835d79ea1905836737c9b758.tar.gz
gentoo-2-351c7fc91529fe3c835d79ea1905836737c9b758.tar.bz2
gentoo-2-351c7fc91529fe3c835d79ea1905836737c9b758.zip
Initial import. Ebuild submitted by Samuel Robyr <samuel.robyr@gmail.com>; bug #73407.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-tex/html2latex/html2latex-1.1.ebuild')
-rw-r--r--dev-tex/html2latex/html2latex-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1.ebuild b/dev-tex/html2latex/html2latex-1.1.ebuild
new file mode 100644
index 000000000000..be58eeafa2c2
--- /dev/null
+++ b/dev-tex/html2latex/html2latex-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/html2latex/html2latex-1.1.ebuild,v 1.1 2005/02/16 14:54:51 usata Exp $
+
+inherit perl-module
+
+DESCRIPTION="Perl script to convert HTML files into formatted LaTeX"
+HOMEPAGE="http://html2latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/html2latex/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="imagemagick libwww"
+
+DEPEND="dev-perl/HTML-Tree
+ dev-perl/XML-Simple
+ imagemagick? ( media-gfx/imagemagick )
+ libwww? ( dev-perl/libwww-perl )"
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_prep
+ perl-module_src_compile
+}
+
+
+src_install() {
+ dobin html2latex
+ doman html2latex.1
+ dodoc README TODO
+
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_install
+}