summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-10-31 12:22:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-10-31 12:22:37 +0000
commit6a008385406ebc47d059cfc64d005504c601880e (patch)
treec8b37be48a4b7a6024a5172827ab7a3e917eb0a0 /dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild
parentImproved text about possible ABI changes, noticed by mark_alec. (diff)
downloadgentoo-2-6a008385406ebc47d059cfc64d005504c601880e.tar.gz
gentoo-2-6a008385406ebc47d059cfc64d005504c601880e.tar.bz2
gentoo-2-6a008385406ebc47d059cfc64d005504c601880e.zip
version bump, bug #196999
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild')
-rw-r--r--dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild b/dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild
new file mode 100644
index 000000000000..686c84dda3d0
--- /dev/null
+++ b/dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latex2rtf/latex2rtf-1.9.18.ebuild,v 1.1 2007/10/31 12:22:37 aballier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="LaTeX to RTF converter"
+HOMEPAGE="http://latex2rtf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/latex2rtf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+IUSE="doc test"
+
+# It needs some german language support packages for the tests
+DEPEND="virtual/tetex
+ media-gfx/imagemagick
+ test? ( || (
+ dev-texlive/texlive-langgerman
+ app-text/tetex
+ app-text/cstetex
+ app-text/ptex
+ )
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-Makefile-gentoo.diff"
+ epatch "${FILESDIR}/${PN}-1.9.16-direntry.patch"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "make install failed"
+ dodoc README doc/latex2rtf.txt
+ # if doc is not used, only the text version is intalled.
+ if use doc; then
+ dohtml doc/latex2rtf.html
+ dodoc doc/latex2rtf.pdf doc/latex2rtf.txt
+ sed -i "s/\r/\n/g" doc/latex2rtf.info
+ doinfo doc/latex2rtf.info
+ fi
+}