summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-02-24 04:28:37 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-02-24 04:28:37 +0000
commit78ee8815725b7316b7047d264673085930bd8e9b (patch)
treeb3c99399a6845e1cdbcd4a4e2787b48c31d2ff88 /dev-util/anjuta
parentVersion bump. Remove old versions. (diff)
downloadgentoo-2-78ee8815725b7316b7047d264673085930bd8e9b.tar.gz
gentoo-2-78ee8815725b7316b7047d264673085930bd8e9b.tar.bz2
gentoo-2-78ee8815725b7316b7047d264673085930bd8e9b.zip
version bump from upstream (bug #168101)
(Portage version: 2.1.2-r10)
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/ChangeLog8
-rw-r--r--dev-util/anjuta/anjuta-2.1.1_beta1.ebuild104
-rw-r--r--dev-util/anjuta/files/digest-anjuta-2.1.1_beta13
3 files changed, 114 insertions, 1 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index 451bba6560fe..10bad1399f3f 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/anjuta
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.63 2007/02/02 20:50:33 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.64 2007/02/24 04:28:37 compnerd Exp $
+
+*anjuta-2.1.1_beta1 (24 Feb 2007)
+
+ 24 Feb 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +anjuta-2.1.1_beta1.ebuild:
+ Version bump from upstream (bug #168101)
02 Feb 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+files/anjuta-2.1.0-sandbox-fix.patch, anjuta-2.1.0_beta1.ebuild:
diff --git a/dev-util/anjuta/anjuta-2.1.1_beta1.ebuild b/dev-util/anjuta/anjuta-2.1.1_beta1.ebuild
new file mode 100644
index 000000000000..14a0904b011d
--- /dev/null
+++ b/dev-util/anjuta/anjuta-2.1.1_beta1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-2.1.1_beta1.ebuild,v 1.1 2007/02/24 04:28:37 compnerd Exp $
+
+inherit eutils gnome2 eutils autotools
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="http://www.anjuta.org"
+SRC_URI="mirror://sourceforge/${PN}/${PF//_*}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc glade inherit-graph sourceview subversion valgrind"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.8.0
+ >=gnome-base/orbit-2.6.0
+ >=gnome-base/libglade-2.3.0
+ >=gnome-base/libgnome-2.12.0
+ >=gnome-base/libgnomeui-2.12.0
+ >=gnome-base/libgnomeprint-2.12.0
+ >=gnome-base/libgnomeprintui-2.12.0
+ >=gnome-base/gnome-vfs-2.12.0
+ >=gnome-base/gconf-2.12.0
+ >=x11-libs/vte-0.13.1
+ >=dev-libs/libxml2-2.4.23
+ >=x11-libs/pango-1.1.1
+ >=dev-libs/gdl-0.7.0
+ >=dev-util/devhelp-0.13
+ >=dev-libs/gnome-build-0.1.4
+ >=dev-libs/libpcre-5.0
+ >=x11-libs/libwnck-2.12
+ >=sys-devel/binutils-2.15.92
+ dev-libs/libxslt
+ glade? ( >=dev-util/glade-3.1.4 )
+ inherit-graph? ( >=media-gfx/graphviz-2.2.1 )
+ sourceview? (
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/libgnome-2.14.0
+ >=x11-libs/gtksourceview-1.4.0
+ )
+ subversion? (
+ >=dev-util/subversion-1.1.4
+ >=net-misc/neon-0.24.5
+ dev-libs/apr
+ )
+ valgrind? ( dev-util/valgrind )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/autogen
+ >=sys-devel/gettext-0.14
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.20
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+# The build is finiky
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S="${WORKDIR}/${PF//_*}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-plugin-devhelp \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable glade plugin-glade) \
+ $(use_enable valgrind plugin-valgrind) \
+ $(use_enable sourceview plugin-sourceview) \
+ $(use_enable subversion plugin-subversion) \
+ $(use_enable inherit-graph plugin-class-inheritance)"
+
+ # Enable scintilla by default
+ if ! use sourceview ; then
+ G2CONF="${G2CONF} --enable-plugin-scintilla"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ cd ${S}
+
+ # Patch to prevent an access violation (bug #164740)
+ epatch ${FILESDIR}/${PN}-2.1.0-sandbox-fix.patch
+}
+
+src_install() {
+ # Install user docs into /usr/share/doc/${PF}/
+ sed -i -e "s:doc/${PN}:doc/${PF}:g" Makefile
+ sed -i -e "s:doc/${PN}:doc/${PF}/html:g" doc/Makefile
+
+ gnome2_src_install
+ prepalldocs
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebeep 1
+ einfo "Some project templates may require additional development"
+ einfo "libraries to function correctly. It goes beyond the scope"
+ einfo "of this ebuild to provide them."
+ epause 5
+}
diff --git a/dev-util/anjuta/files/digest-anjuta-2.1.1_beta1 b/dev-util/anjuta/files/digest-anjuta-2.1.1_beta1
new file mode 100644
index 000000000000..e3067d2656ab
--- /dev/null
+++ b/dev-util/anjuta/files/digest-anjuta-2.1.1_beta1
@@ -0,0 +1,3 @@
+MD5 8113f280db27dcf923748ca66c0c19fa anjuta-2.1.1.tar.bz2 5333622
+RMD160 96845d7679ce02069aa4e633ce9f283bdc982c08 anjuta-2.1.1.tar.bz2 5333622
+SHA256 581f7ee359bbe5835b6fc5759e0318a7a270d5e686f4eaaf726e1066b1c8bdbc anjuta-2.1.1.tar.bz2 5333622