summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-29 16:58:07 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-29 16:58:07 +0000
commit457ba5427aeddf28016ac970d3aa705fe0b70573 (patch)
tree9c51cc53d1b27e267f3a42f22908722b7a0896be /dev-util/bitkeeper
parentupdate plugins for 0.8.2 (Manifest recommit) (diff)
downloadgentoo-2-457ba5427aeddf28016ac970d3aa705fe0b70573.tar.gz
gentoo-2-457ba5427aeddf28016ac970d3aa705fe0b70573.tar.bz2
gentoo-2-457ba5427aeddf28016ac970d3aa705fe0b70573.zip
Version bump.
Diffstat (limited to 'dev-util/bitkeeper')
-rw-r--r--dev-util/bitkeeper/ChangeLog7
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.2.2b.ebuild88
-rw-r--r--dev-util/bitkeeper/files/digest-bitkeeper-3.2.2b9
3 files changed, 103 insertions, 1 deletions
diff --git a/dev-util/bitkeeper/ChangeLog b/dev-util/bitkeeper/ChangeLog
index cc73a001b714..a84386ebea1b 100644
--- a/dev-util/bitkeeper/ChangeLog
+++ b/dev-util/bitkeeper/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-util/bitkeeper
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.19 2004/06/25 09:57:52 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/ChangeLog,v 1.20 2004/06/29 16:58:06 spock Exp $
# README: bitkeeper only offers the latest version of bitkeeper for download,
# so we need to be all over marking new versions stable
+*bitkeeper-3.2.2b (29 Jun 2004)
+
+ 29 Jun 2004; Michal Januszewski <spock@gentoo.org> +bitkeeper-3.2.2b.ebuild:
+ Version bump.
+
25 Jun 2004; David Holm <dholm@gentoo.org> -bitkeeper-3.0.3.ebuild,
-bitkeeper-3.0.4.ebuild, bitkeeper-3.2.2.ebuild:
Applied anti-spock patch.
diff --git a/dev-util/bitkeeper/bitkeeper-3.2.2b.ebuild b/dev-util/bitkeeper/bitkeeper-3.2.2b.ebuild
new file mode 100644
index 000000000000..93b53b993f30
--- /dev/null
+++ b/dev-util/bitkeeper/bitkeeper-3.2.2b.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.2.2b.ebuild,v 1.1 2004/06/29 16:58:06 spock Exp $
+
+DESCRIPTION="A scalable configuration management system."
+HOMEPAGE="http://www.bitkeeper.com/"
+SRC_URI="alpha? ( bk-${PV}-alpha-glibc22-linux.bin )
+ arm? ( bk-${PV}-arm-glibc21-linux.bin )
+ hppa? ( bk-${PV}-hppa-glibc22-linux.bin )
+ ia64? ( bk-${PV}-ia64-glibc22-linux.bin )
+ mips? ( bk-${PV}-mips-glibc22-linux.bin )
+ ppc? ( bk-${PV}-powerpc-glibc21-linux.bin )
+ s390? ( bk-${PV}-s390-glibc22-linux.bin )
+ sparc? ( bk-${PV}-sparc-glibc21-linux.bin )
+ x86? ( bk-${PV}-x86-glibc23-linux.bin )"
+LICENSE="BKL"
+SLOT="0"
+KEYWORDS="alpha arm hppa ia64 mips ppc s390 sparc x86"
+RESTRICT="fetch"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="virtual/glibc
+ >=dev-lang/tcl-8.3.4
+ X? ( >=dev-lang/tk-8.3.4 )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ eerror "You need to perform the following steps to install this package:"
+ eerror " - Sign up at ${HOMEPAGE}"
+ eerror " - Check your email and visit the download location"
+ eerror " - Download ${A} and place it in ${DISTDIR}"
+ eerror " - emerge this package again"
+ eerror "Run 'bk regression' to verify the installation. (Recommended)"
+}
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ dodir /opt /usr/share/man/man1 /usr/bin
+ cd ${T}
+ cp ${DISTDIR}/${A} .
+ chmod 755 ${A}
+ BK_NOLINKS='y' ./${A} ${D}/opt/${P}
+ cd ${D}
+
+ # BK includes two copies of most man pages; the second copy is a
+ # hard link to the first with its filename prefixed with
+ # 'bk-'. 'prepman' breaks these hard links, so use a
+ # workaround. Furthermore, we want only the 'bk-' versions to be
+ # in ${MANPATH} since there are naming conflicts, so install
+ # symlinks into /usr/share/man. (For example BK includes a
+ # less-detailed man page for grep which would override the
+ # /usr/share/man version.)
+
+ prepman /opt/${P}
+
+ find opt/${P}/man -iname 'bk-*' -printf '
+ F=`echo %f|sed -e "s/bk-//"`
+ rm -f %h/$F
+ dohard /%h/%f /%h/$F
+ dosym /%h/%f /usr/share/man/%P' >${T}/links.sh
+ . ${T}/links.sh
+
+ dosym /opt/${P}/man/man1/bk.1.gz /usr/share/man/man1/bk.1.gz
+
+ # mimic "bk links /opt/${P} /usr/bin"
+ dosym /opt/${P}/admin /usr/bin/admin
+ dosym /opt/${P}/bk /usr/bin/bk
+ dosym /opt/${P}/delta /usr/bin/delta
+ dosym /opt/${P}/get /usr/bin/get
+ dosym /opt/${P}/prs /usr/bin/prs
+ dosym /opt/${P}/rmdel /usr/bin/rmdel
+ dosym /opt/${P}/unget /usr/bin/unget
+}
+
+pkg_postinst() {
+ if grep -H bitkeeper /etc/man.conf; then
+ eerror "Previous BitKeeper ebuilds induced a misconfiguration when sys-apps/man was"
+ eerror "next upgraded. You appear to have fallen victim--edit /etc/man.conf and look"
+ eerror "for the definition of CMP. It should refer to /usr/bin/cmp, not the"
+ eerror "BitKeeper cmp."
+ eerror "For more information, see bugs #18247 and #21638."
+ fi
+}
diff --git a/dev-util/bitkeeper/files/digest-bitkeeper-3.2.2b b/dev-util/bitkeeper/files/digest-bitkeeper-3.2.2b
new file mode 100644
index 000000000000..c1c9ef5a446f
--- /dev/null
+++ b/dev-util/bitkeeper/files/digest-bitkeeper-3.2.2b
@@ -0,0 +1,9 @@
+MD5 aac4293b7e0c22cd500d1bd20fcc1028 bk-3.2.2b-alpha-glibc22-linux.bin 3604208
+MD5 366942355fef4813e9153f1ae66dc3ea bk-3.2.2b-arm-glibc21-linux.bin 3139364
+MD5 1d19edc38c3ff5c1a94354f527a87b73 bk-3.2.2b-hppa-glibc22-linux.bin 3402732
+MD5 d0c91d66d990681e8c22a6a939b013bc bk-3.2.2b-ia64-glibc22-linux.bin 4173056
+MD5 c5092d1e2f7a989478f61b211e3a5db9 bk-3.2.2b-mips-glibc22-linux.bin 3419368
+MD5 80b37dd69e258223a9f28098eb052f58 bk-3.2.2b-powerpc-glibc21-linux.bin 3201292
+MD5 16c3f451c6a0c135616570b088fd3aa8 bk-3.2.2b-s390-glibc22-linux.bin 3149872
+MD5 ccb04b23869e307e8933a75893666bdf bk-3.2.2b-sparc-glibc21-linux.bin 3142736
+MD5 09f34453b415997c182d20ee0456c023 bk-3.2.2b-x86-glibc23-linux.bin 3073756