summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-05-16 09:40:05 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-05-16 09:40:05 +0000
commitaf2ab5389de6a59bbe259e49fd71774daec4649f (patch)
tree500cfb780d85f2258d5e703df79741baae25d7f2 /dev-util/boost-build
parentVersion bump. (diff)
downloadgentoo-2-af2ab5389de6a59bbe259e49fd71774daec4649f.tar.gz
gentoo-2-af2ab5389de6a59bbe259e49fd71774daec4649f.tar.bz2
gentoo-2-af2ab5389de6a59bbe259e49fd71774daec4649f.zip
Respect multilib during building Python-related stuff, bug #496446
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/ChangeLog6
-rw-r--r--dev-util/boost-build/boost-build-1.53.0.ebuild11
-rw-r--r--dev-util/boost-build/boost-build-1.54.0.ebuild11
-rw-r--r--dev-util/boost-build/boost-build-1.55.0.ebuild11
4 files changed, 26 insertions, 13 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 897aac9c361d..d3f3af12a57a 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.125 2014/04/15 15:52:10 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.126 2014/05/16 09:40:05 pinkbyte Exp $
+
+ 16 May 2014; Sergey Popov <pinkbyte@gentoo.org> boost-build-1.53.0.ebuild,
+ boost-build-1.54.0.ebuild, boost-build-1.55.0.ebuild:
+ Respect multilib during building Python-related stuff, bug #496446
15 Apr 2014; Sergey Popov <pinkbyte@gentoo.org> -boost-build-1.49.0.ebuild,
-files/boost-build-1.42-env-whitespace.patch:
diff --git a/dev-util/boost-build/boost-build-1.53.0.ebuild b/dev-util/boost-build/boost-build-1.53.0.ebuild
index 4df1f1d5e430..7746d14624a5 100644
--- a/dev-util/boost-build/boost-build-1.53.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.53.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.53.0.ebuild,v 1.1 2013/02/12 15:39:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.53.0.ebuild,v 1.2 2014/05/16 09:40:05 pinkbyte Exp $
EAPI="5"
PYTHON_DEPEND="python? 2"
-inherit eutils flag-o-matic python toolchain-funcs versionator
+inherit eutils flag-o-matic multilib python toolchain-funcs versionator
MY_PV=$(replace_all_version_separators _)
@@ -48,8 +48,11 @@ src_prepare() {
"${FILESDIR}/${PN}-1.52.0-darwin-no-python-framework.patch"
# Remove stripping option
+ # Fix python components build on multilib systems, bug #496446
cd "${S}/engine"
- sed -i -e 's|-s\b||' \
+ sed -i \
+ -e 's|-s\b||' \
+ -e "/libpython/s/lib ]/$(get_libdir) ]/" \
build.jam || die "sed failed"
# Force regeneration
diff --git a/dev-util/boost-build/boost-build-1.54.0.ebuild b/dev-util/boost-build/boost-build-1.54.0.ebuild
index 68b376c66f4f..24c66ef0e67c 100644
--- a/dev-util/boost-build/boost-build-1.54.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.54.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.54.0.ebuild,v 1.1 2013/08/27 08:46:00 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.54.0.ebuild,v 1.2 2014/05/16 09:40:05 pinkbyte Exp $
EAPI="5"
PYTHON_DEPEND="python? 2"
-inherit eutils flag-o-matic python toolchain-funcs versionator
+inherit eutils flag-o-matic multilib python toolchain-funcs versionator
MY_PV=$(replace_all_version_separators _)
@@ -48,8 +48,11 @@ src_prepare() {
"${FILESDIR}/${PN}-1.54.0-support_dots_in_python-buildid.patch"
# Remove stripping option
+ # Fix python components build on multilib systems, bug #496446
cd "${S}/engine"
- sed -i -e 's|-s\b||' \
+ sed -i \
+ -e 's|-s\b||' \
+ -e "/libpython/s/lib ]/$(get_libdir) ]/" \
build.jam || die "sed failed"
# Force regeneration
diff --git a/dev-util/boost-build/boost-build-1.55.0.ebuild b/dev-util/boost-build/boost-build-1.55.0.ebuild
index 531fb28893d8..73639498c183 100644
--- a/dev-util/boost-build/boost-build-1.55.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.55.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.55.0.ebuild,v 1.1 2013/11/14 16:56:02 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.55.0.ebuild,v 1.2 2014/05/16 09:40:05 pinkbyte Exp $
EAPI="5"
PYTHON_DEPEND="python? 2"
-inherit eutils flag-o-matic python toolchain-funcs versionator
+inherit eutils flag-o-matic multilib python toolchain-funcs versionator
MY_PV=$(replace_all_version_separators _)
@@ -48,8 +48,11 @@ src_prepare() {
"${FILESDIR}/${PN}-1.54.0-support_dots_in_python-buildid.patch"
# Remove stripping option
+ # Fix python components build on multilib systems, bug #496446
cd "${S}/engine"
- sed -i -e 's|-s\b||' \
+ sed -i \
+ -e 's|-s\b||' \
+ -e "/libpython/s/lib ]/$(get_libdir) ]/" \
build.jam || die "sed failed"
# Force regeneration