summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-10-30 23:29:36 +0000
committerMarien Zwart <marienz@gentoo.org>2006-10-30 23:29:36 +0000
commitcd68134dd5cc10318cbebaebc0f230e58f0af38a (patch)
treebc1b828923337c01bf2b545b78e4c492279aadfa /dev-util/bzr/bzr-0.12.ebuild
parentAdd >=sys-libs/libsemanage-1.6.17 as well since it needs masked sys-libs/libs... (diff)
downloadgentoo-2-cd68134dd5cc10318cbebaebc0f230e58f0af38a.tar.gz
gentoo-2-cd68134dd5cc10318cbebaebc0f230e58f0af38a.tar.bz2
gentoo-2-cd68134dd5cc10318cbebaebc0f230e58f0af38a.zip
Version bump, add curl USE flag.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'dev-util/bzr/bzr-0.12.ebuild')
-rw-r--r--dev-util/bzr/bzr-0.12.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/bzr/bzr-0.12.ebuild b/dev-util/bzr/bzr-0.12.ebuild
new file mode 100644
index 000000000000..d9488c46fc50
--- /dev/null
+++ b/dev-util/bzr/bzr-0.12.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.12.ebuild,v 1.1 2006/10/30 23:29:36 marienz Exp $
+
+inherit distutils bash-completion elisp-common eutils
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="next generation distributed version control"
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/releases/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="curl emacs test"
+
+python_rdep="dev-python/celementtree
+ >=dev-python/paramiko-1.5
+ curl? ( dev-python/pycurl )"
+DEPEND=">=dev-lang/python-2.4
+ emacs? ( virtual/emacs )
+ test? ( $python_rdep )"
+RDEPEND=">=dev-lang/python-2.4
+ $python_rdep"
+
+PYTHON_MODNAME="bzrlib"
+
+DOCS="HACKING NEWS NEWS.developers"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the manpage in /usr/share/man instead of /usr/man
+ epatch "${FILESDIR}/${PN}-0.10-fix-manpage-location.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use emacs; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/bzr-mode.el*
+ elisp-site-file-install "${FILESDIR}/70bzr-gentoo.el"
+ fi
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ einfo "If you just upgraded from a version of bzr older than 0.9"
+ einfo "you should rename your ~/.bazaar/branches.conf to locations.conf"
+ einfo "(see /usr/share/doc/${PF}/NEWS.gz)"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}
+
+src_test() {
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+}