summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-17 20:10:26 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-17 20:10:26 +0000
commitd5c15015307e865c4d937e7a19e604619c55fdfb (patch)
treeef173d3dfa2c7756008ef76401bb1280994406b9 /dev-util/cmake
parentdev-vcs/rsvndump: Bump to 0.5.3 (diff)
downloadgentoo-2-d5c15015307e865c4d937e7a19e604619c55fdfb.tar.gz
gentoo-2-d5c15015307e865c4d937e7a19e604619c55fdfb.tar.bz2
gentoo-2-d5c15015307e865c4d937e7a19e604619c55fdfb.zip
Port more-no_host_paths patch since it is really necessary for proper operation in Prefix, bump to EAPI=3. Acked by scarabeus
(Portage version: 2.2.00.15819-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-2.8.1.ebuild7
-rw-r--r--dev-util/cmake/files/cmake-2.8.1-more-no_host_paths.patch108
3 files changed, 117 insertions, 5 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index d10d9e583547..9b3939ce3980 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.131 2010/03/17 19:33:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.132 2010/03/17 20:10:25 grobian Exp $
+
+ 17 Mar 2010; Fabian Groffen <grobian@gentoo.org> cmake-2.8.1.ebuild,
+ +files/cmake-2.8.1-more-no_host_paths.patch:
+ Port more-no_host_paths patch since it is really necessary for proper
+ operation in Prefix, bump to EAPI=3.
*cmake-2.8.1 (17 Mar 2010)
diff --git a/dev-util/cmake/cmake-2.8.1.ebuild b/dev-util/cmake/cmake-2.8.1.ebuild
index 117446ba81b8..35682f7b14f2 100644
--- a/dev-util/cmake/cmake-2.8.1.ebuild
+++ b/dev-util/cmake/cmake-2.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.1.ebuild,v 1.1 2010/03/17 19:33:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.1.ebuild,v 1.2 2010/03/17 20:10:25 grobian Exp $
-EAPI="2"
+EAPI="3"
inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
@@ -50,13 +50,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
"${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
"${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
+ "${FILESDIR}"/${PN}-2.8.1-more-no_host_paths.patch
)
src_prepare() {
base_src_prepare
- use prefix || EPREFIX=
-
# Add gcc libs to the default link paths
sed -i \
-e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib|g" \
diff --git a/dev-util/cmake/files/cmake-2.8.1-more-no_host_paths.patch b/dev-util/cmake/files/cmake-2.8.1-more-no_host_paths.patch
new file mode 100644
index 000000000000..0558b34e6efd
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.1-more-no_host_paths.patch
@@ -0,0 +1,108 @@
+Set some proper paths to make cmake find our tools.
+Original patch by Heiko Przybyl
+
+The ebuild now adds an extra / at the end of $EPREFIX so that it is
+never the empty string (so that CMAKE_SYSTEM_PREFIX_PATH remains
+correct)
+
+--- cmake-2.8.0/Modules/Platform/Darwin.cmake
++++ cmake-2.8.0/Modules/Platform/Darwin.cmake
+@@ -213,19 +213,23 @@
+
+
+
+-# default to searching for frameworks first
+-SET(CMAKE_FIND_FRAMEWORK FIRST)
++# default to searching for frameworks last
++SET(CMAKE_FIND_FRAMEWORK LAST)
+ # set up the default search directories for frameworks
+ SET(CMAKE_SYSTEM_FRAMEWORK_PATH
++ @GENTOO_PORTAGE_EPREFIX@Frameworks
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
+ ~/Library/Frameworks
+ /Library/Frameworks
+ /Network/Library/Frameworks
+ /System/Library/Frameworks)
+
+-# default to searching for application bundles first
+-SET(CMAKE_FIND_APPBUNDLE FIRST)
++# default to searching for application bundles last
++SET(CMAKE_FIND_APPBUNDLE LAST)
+ # set up the default search directories for application bundles
+ SET(CMAKE_SYSTEM_APPBUNDLE_PATH
++ @GENTOO_PORTAGE_EPREFIX@Applications
++ @GENTOO_PORTAGE_EPREFIX@usr/bin
+ ~/Applications
+ /Applications
+ /Developer/Applications)
+--- cmake-2.8.0/Modules/Platform/UnixPaths.cmake
++++ cmake-2.8.0/Modules/Platform/UnixPaths.cmake
+@@ -33,6 +33,7 @@
+ # search types.
+ LIST(APPEND CMAKE_SYSTEM_PREFIX_PATH
+ # Standard
++ @GENTOO_PORTAGE_EPREFIX@usr/local @GENTOO_PORTAGE_EPREFIX@usr @GENTOO_PORTAGE_EPREFIX@
+ /usr/local /usr /
+
+ # CMake install location
+@@ -44,43 +45,39 @@
+
+ # List common include file locations not under the common prefixes.
+ LIST(APPEND CMAKE_SYSTEM_INCLUDE_PATH
+- # Windows API on Cygwin
+- /usr/include/w32api
+-
+- # X11
+- /usr/X11R6/include /usr/include/X11
+-
+- # Other
+- /opt/local/include /usr/pkg/include
+- /opt/csw/include /opt/include
+- /usr/openwin/include
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ )
+
+ LIST(APPEND CMAKE_SYSTEM_LIBRARY_PATH
+- # Windows API on Cygwin
+- /usr/lib/w32api
+-
+- # X11
+- /usr/X11R6/lib /usr/lib/X11
+-
+- # Other
+- /opt/local/lib /usr/pkg/lib
+- /opt/csw/lib /opt/lib
+- /usr/openwin/lib
++ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
++ @GENTOO_PORTAGE_GCCLIBDIR@
++ @GENTOO_PORTAGE_EPREFIX@usr/lib64
++ @GENTOO_PORTAGE_EPREFIX@usr/lib32
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
++ @GENTOO_PORTAGE_EPREFIX@lib
+ )
+
+ LIST(APPEND CMAKE_SYSTEM_PROGRAM_PATH
+- /usr/pkg/bin
++ @GENTOO_PORTAGE_EPREFIX@usr/bin
++ @GENTOO_PORTAGE_EPREFIX@bin
+ )
+
+ LIST(APPEND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
++ @GENTOO_PORTAGE_GCCLIBDIR@/gcc
++ @GENTOO_PORTAGE_GCCLIBDIR@
++ @GENTOO_PORTAGE_EPREFIX@usr/lib64
++ @GENTOO_PORTAGE_EPREFIX@usr/lib32
++ @GENTOO_PORTAGE_EPREFIX@usr/lib
++ @GENTOO_PORTAGE_EPREFIX@lib
+ /lib /usr/lib /usr/lib32 /usr/lib64
+ )
+
+ LIST(APPEND CMAKE_C_IMPLICIT_INCLUDE_DIRECTORIES
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ /usr/include
+ )
+ LIST(APPEND CMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES
++ @GENTOO_PORTAGE_EPREFIX@usr/include
+ /usr/include
+ )
+