summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2005-02-04 15:59:05 +0000
committerRainer Groesslinger <scandium@gentoo.org>2005-02-04 15:59:05 +0000
commitd96236357e0efff150878df17cdf7cadce740794 (patch)
treee98d4a10007b248b248da317c900a456d3da4de4 /dev-util/cvs/cvs-1.11.19.ebuild
parentVersion bump. (diff)
downloadgentoo-2-d96236357e0efff150878df17cdf7cadce740794.tar.gz
gentoo-2-d96236357e0efff150878df17cdf7cadce740794.tar.bz2
gentoo-2-d96236357e0efff150878df17cdf7cadce740794.zip
version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-util/cvs/cvs-1.11.19.ebuild')
-rw-r--r--dev-util/cvs/cvs-1.11.19.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/cvs/cvs-1.11.19.ebuild b/dev-util/cvs/cvs-1.11.19.ebuild
new file mode 100644
index 000000000000..f550e822e3ba
--- /dev/null
+++ b/dev-util/cvs/cvs-1.11.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.11.19.ebuild,v 1.1 2005/02/04 15:59:05 scandium Exp $
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.cvshome.org/"
+SRC_URI="http://ccvs.cvshome.org/files/documents/19/742/${P}.tar.bz2
+ doc? ( http://ccvs.cvshome.org/files/documents/19/737/cederqvist-${PV}.html.tar.bz2
+ http://ccvs.cvshome.org/files/documents/19/738/cederqvist-${PV}.pdf
+ http://ccvs.cvshome.org/files/documents/19/739/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="doc emacs"
+
+DEPEND="virtual/libc
+ >=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ econf --with-tmpdir=/tmp || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}