summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-08-21 13:31:09 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-08-21 13:31:09 +0000
commitc3345a8d460b9cd5648939bf9aa25791eba19662 (patch)
tree75920dcded821cf080e1b06106bf998879d61e0d /dev-util/cvs2svn/cvs2svn-2.1.1.ebuild
parentfix issue with libpng's API change. bug #235072 (diff)
downloadgentoo-2-c3345a8d460b9cd5648939bf9aa25791eba19662.tar.gz
gentoo-2-c3345a8d460b9cd5648939bf9aa25791eba19662.tar.bz2
gentoo-2-c3345a8d460b9cd5648939bf9aa25791eba19662.zip
version bump. bug #219415
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'dev-util/cvs2svn/cvs2svn-2.1.1.ebuild')
-rw-r--r--dev-util/cvs2svn/cvs2svn-2.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cvs2svn/cvs2svn-2.1.1.ebuild b/dev-util/cvs2svn/cvs2svn-2.1.1.ebuild
new file mode 100644
index 000000000000..f690ba7a0a4a
--- /dev/null
+++ b/dev-util/cvs2svn/cvs2svn-2.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.1 2008/08/21 13:31:09 cardoe Exp $
+
+inherit distutils
+
+FILEVER="42521"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ >=dev-util/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ app-text/rcs"
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2svn-example.options {profile-repos,show-db,verify-cvs2svn}.py
+ doman cvs2svn.1
+}
+
+src_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ python run-tests.py || die "tests failed"
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}