summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 15:01:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 15:01:58 +0000
commitdd4d0b836d8273927e92954757f2a587c9e89ca0 (patch)
treeaa98badeae8cfed2acb51bd248c3dcfdadbd0be5 /dev-util/ddd
parentAdding samba-3.2.11 ebuild based on the 3.2.8 ebuild from bug #231273. Thanks... (diff)
downloadgentoo-2-dd4d0b836d8273927e92954757f2a587c9e89ca0.tar.gz
gentoo-2-dd4d0b836d8273927e92954757f2a587c9e89ca0.tar.bz2
gentoo-2-dd4d0b836d8273927e92954757f2a587c9e89ca0.zip
Bump to 3.3.12. Fixes #252261
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ddd')
-rw-r--r--dev-util/ddd/ChangeLog9
-rw-r--r--dev-util/ddd/ddd-3.3.12.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-util/ddd/ChangeLog b/dev-util/ddd/ChangeLog
index 6938860e653d..e60ebfefd74e 100644
--- a/dev-util/ddd/ChangeLog
+++ b/dev-util/ddd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ddd
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.51 2008/04/21 17:19:55 phreak Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.52 2009/04/23 15:01:58 patrick Exp $
+
+*ddd-3.3.12 (23 Apr 2009)
+
+ 23 Apr 2009; Patrick Lauer <patrick@gentoo.org> +ddd-3.3.12.ebuild:
+ Bump to 3.3.12. Fixes #252261
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/dev-util/ddd/ddd-3.3.12.ebuild b/dev-util/ddd/ddd-3.3.12.ebuild
new file mode 100644
index 000000000000..27a4ac19b281
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.12.ebuild,v 1.1 2009/04/23 15:01:58 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+#SRC_URI="mirror://sourceforge/ddd/${P}.tar.gz"
+SRC_URI="http://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libXp
+ >=sys-devel/gcc-3
+ >=sys-devel/gdb-6.4
+ x11-libs/openmotif"
+RDEPEND="${DEPEND}
+ sci-visualization/gnuplot"
+
+RESTRICT="test"
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS}"
+ econf || die
+ cd "${S}"/ddd
+ emake version.h build.h host.h root.h configinfo.C Ddd.ad.h || die "Failed to build headers"
+ cd "${S}"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/lib
+ # If using internal libiberty.a, need to pass
+ # $tooldir to 'make install', else we get
+ # sandbox errors ... bug #4614.
+ # <azarah@gentoo.org> 05 Dec 2002
+ einstall tooldir="${D}/usr" || die
+
+ # This one is from binutils
+ [ -f "${D}"/usr/lib/libiberty.a ] && rm -f "${D}"/usr/lib/libiberty.a
+ # Remove empty dir ...
+ rmdir "${D}"/usr/lib || :
+
+ mv "${S}"/doc/README "${S}"/doc/README-DOC
+ dodoc AUTHORS COPYING* CREDITS INSTALL NEWS* PROBLEMS README* TIPS TODO
+
+ mv "${S}"/doc/* "${D}"/usr/share/doc/${PF}
+}