summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2001-11-28 04:16:02 +0000
committerBruce A. Locke <blocke@gentoo.org>2001-11-28 04:16:02 +0000
commit64d46700a06caad3b95fbeda8e932fd58fd4f2a0 (patch)
treeafe312dfff03b4e8a47100eec1ff69a0938e91c9 /dev-util/diffstat/diffstat-1.29.ebuild
parentAdded package for the daemon at http://linecontrol.sourceforge.net. (diff)
downloadgentoo-2-64d46700a06caad3b95fbeda8e932fd58fd4f2a0.tar.gz
gentoo-2-64d46700a06caad3b95fbeda8e932fd58fd4f2a0.tar.bz2
gentoo-2-64d46700a06caad3b95fbeda8e932fd58fd4f2a0.zip
diffstat 1.29: first version in portage
Diffstat (limited to 'dev-util/diffstat/diffstat-1.29.ebuild')
-rw-r--r--dev-util/diffstat/diffstat-1.29.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/diffstat/diffstat-1.29.ebuild b/dev-util/diffstat/diffstat-1.29.ebuild
new file mode 100644
index 000000000000..f3560d9da570
--- /dev/null
+++ b/dev-util/diffstat/diffstat-1.29.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffstat/diffstat-1.29.ebuild,v 1.1 2001/11/28 04:16:02 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="diffstat reads the output of diff and displays a histogram of the insertions, deletions, and modifications per-file"
+SRC_URI="ftp://invisible-island.net/diffstat/diffstat.tar.gz"
+HOMEPAGE="http://dickey.his.com/diffstat/diffstat.html"
+DEPEND="sys-apps/diffutils"
+
+src_compile() {
+ ./configure --prefix=/usr --host="${CHOST}"
+ assert
+
+ make CFLAGS="-Wshadow -Wconversion -Wstrict-prototypes -Wmissing-prototypes ${CFLAGS}" || die
+}
+
+src_install() {
+ dobin diffstat
+ doman diffstat.1
+ dodoc README CHANGES
+}