summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 10:00:18 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-28 10:00:18 +0000
commitbf24b16eb699e6bae6d62fb195df750bc0e7edc5 (patch)
tree397d2bc2e8d30ab9eb0a818dae639f679e2d6e93 /dev-util/eric/eric-4.3.9.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-bf24b16eb699e6bae6d62fb195df750bc0e7edc5.tar.gz
gentoo-2-bf24b16eb699e6bae6d62fb195df750bc0e7edc5.tar.bz2
gentoo-2-bf24b16eb699e6bae6d62fb195df750bc0e7edc5.zip
Don't use ${PYVER}.
(Portage version: 15495-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric/eric-4.3.9.ebuild')
-rw-r--r--dev-util/eric/eric-4.3.9.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/dev-util/eric/eric-4.3.9.ebuild b/dev-util/eric/eric-4.3.9.ebuild
index fb26169faf6b..6343cf8ec069 100644
--- a/dev-util/eric/eric-4.3.9.ebuild
+++ b/dev-util/eric/eric-4.3.9.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.9.ebuild,v 1.9 2010/02/26 19:29:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.9.ebuild,v 1.10 2010/02/28 10:00:18 arfrever Exp $
EAPI="2"
-NEED_PYTHON="2.4"
SUPPORT_PYTHON_ABIS="1"
inherit eutils python
@@ -29,8 +28,7 @@ IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
DEPEND="dev-python/PyQt4[svg,webkit,X]
dev-python/qscintilla-python"
RDEPEND="${DEPEND}"
-
-RESTRICT_PYTHON_ABIS="3*"
+RESTRICT_PYTHON_ABIS="3.*"
S=${WORKDIR}/${MY_P}
@@ -54,10 +52,8 @@ src_install() {
}
python_execute_function installation
- make_desktop_entry "eric4 --nosplash" \
- eric4 \
- "$(python_get_sitedir -f)/eric4/icons/default/eric.png" \
- "Development;IDE;Qt"
+ doicon eric/icons/default/eric.png
+ make_desktop_entry "eric4 --nosplash" eric4 eric "Development;IDE;Qt"
}
pkg_postinst() {
@@ -65,17 +61,17 @@ pkg_postinst() {
elog
elog "If you want to use eric4 with mod_python, have a look at"
- elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog "\"${ROOT%/}$(python_get_sitedir -f)/eric4/patch_modpython.py\"."
elog
elog "The following packages will give eric extended functionality:"
elog " dev-python/pylint"
elog " dev-python/pysvn"
elog
elog "This version has a plugin interface with plugin-autofetch from"
- elog "the App itself. You may want to check those as well."
+ elog "the application itself. You may want to check those as well."
elog
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup eric4{,config.py,plugins}
}