summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-08-01 17:09:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-08-01 17:09:33 +0000
commitabb4672e88d409e2d59912ae205ffb7de8188a72 (patch)
treebac71cf4b6db0b82630ebf449f418fe2643e34f7 /dev-util/eric
parentVersion bump (upstream fixed 1.9.2 in a different way). (Forced because of pr... (diff)
downloadgentoo-2-abb4672e88d409e2d59912ae205ffb7de8188a72.tar.gz
gentoo-2-abb4672e88d409e2d59912ae205ffb7de8188a72.tar.bz2
gentoo-2-abb4672e88d409e2d59912ae205ffb7de8188a72.zip
Version bump. Fixed bug #303595.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.4.7.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index ac7ed9929b83..55167b7b52db 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.129 2010/07/18 13:46:29 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.130 2010/08/01 17:09:33 arfrever Exp $
+
+*eric-4.4.7 (01 Aug 2010)
+
+ 01 Aug 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +eric-4.4.7.ebuild:
+ Version bump. Fixed bug #303595.
18 Jul 2010; <nixnut@gentoo.org> eric-4.4.4a.ebuild:
ppc stable #324459
diff --git a/dev-util/eric/eric-4.4.7.ebuild b/dev-util/eric/eric-4.4.7.ebuild
new file mode 100644
index 000000000000..3b1520760661
--- /dev/null
+++ b/dev-util/eric/eric-4.4.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.4.7.ebuild,v 1.1 2010/08/01 17:09:33 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
+
+MY_PN="${PN}4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A full featured Python IDE using PyQt4 and QScintilla"
+HOMEPAGE="http://eric-ide.python-projects.org/"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="kde spell"
+
+DEPEND="dev-python/PyQt4[assistant,svg,webkit,X]
+ dev-python/qscintilla-python
+ kde? ( kde-base/pykde4 )"
+RDEPEND="${DEPEND}
+ >=dev-python/chardet-2.0
+ >=dev-python/pygments-1.1
+ dev-python/coverage"
+PDEPEND="spell? ( dev-python/pyenchant )"
+# 2.4 and 2.5 are restricted to avoid conditional dependency on dev-python/simplejson.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+LANGS="cs de es fr it ru tr zh_CN"
+for L in ${LANGS}; do
+ SRC_URI="${SRC_URI}
+ linguas_${L}? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-${L/zh_CN/zh_CN.GB2312}-${PV}.tar.gz )"
+ IUSE="${IUSE} linguas_${L}"
+done
+unset L
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/eric-4.4-no-interactive.patch"
+ epatch "${FILESDIR}/remove_coverage.patch"
+ use kde || epatch "${FILESDIR}/eric-4.4-no-pykde.patch"
+
+ # Delete internal copies of dev-python/chardet, dev-python/coverage,
+ # dev-python/pygments and dev-python/simplejson.
+ rm -fr eric/ThirdParty
+ rm -fr eric/DebugClients/Python/coverage
+ rm -fr eric/DebugClients/Python3/coverage
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" install.py \
+ -z \
+ -b "${EPREFIX}/usr/bin" \
+ -i "${D}" \
+ -d "${EPREFIX}$(python_get_sitedir)" \
+ -c
+ }
+ python_execute_function installation
+
+ doicon eric/icons/default/eric.png
+ make_desktop_entry "eric4 --nosplash" eric4 eric "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_mod_optimize eric4{,config.py,plugins}
+
+ elog
+ elog "If you want to use Eric with mod_python, have a look at"
+ elog "\"${EROOT}$(python_get_sitedir -b -f)/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give Eric extended functionality:"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
+ elog
+ elog "This version has a plugin interface with plugin-autofetch from"
+ elog "the application itself. You may want to check those as well."
+ elog
+}
+
+pkg_postrm() {
+ python_mod_cleanup eric4{,config.py,plugins}
+}