summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-23 19:19:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-23 19:19:50 +0000
commit7081ff335f8607e14ad0238a1a1ea8246bd3d2e4 (patch)
tree68b56b03530849c92ae1abbfe14d8e82e528a9fd /dev-util/git
parentClean up ebuild. (diff)
downloadgentoo-2-7081ff335f8607e14ad0238a1a1ea8246bd3d2e4.tar.gz
gentoo-2-7081ff335f8607e14ad0238a1a1ea8246bd3d2e4.tar.bz2
gentoo-2-7081ff335f8607e14ad0238a1a1ea8246bd3d2e4.zip
Factor out the long emake invocation so that we can consistently call it and avoid triggering a rebuild during install or test.
(Portage version: 2.2_rc18/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'dev-util/git')
-rw-r--r--dev-util/git/ChangeLog6
-rw-r--r--dev-util/git/git-1.6.0.6.ebuild29
2 files changed, 17 insertions, 18 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 9abc615a6c33..271c9fc9607d 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/git
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.310 2008/12/23 17:09:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.311 2008/12/23 19:19:50 robbat2 Exp $
+
+ 23 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> git-1.6.0.6.ebuild:
+ Factor out the long emake invocation so that we can consistently call it
+ and avoid triggering a rebuild during install or test.
23 Dec 2008; Markus Meier <maekke@gentoo.org> git-1.6.0.6.ebuild:
amd64/x86 stable, bug #251343
diff --git a/dev-util/git/git-1.6.0.6.ebuild b/dev-util/git/git-1.6.0.6.ebuild
index cd5f52aa9362..422049d8f199 100644
--- a/dev-util/git/git-1.6.0.6.ebuild
+++ b/dev-util/git/git-1.6.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.0.6.ebuild,v 1.3 2008/12/23 17:09:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.6.0.6.ebuild,v 1.4 2008/12/23 19:19:50 robbat2 Exp $
inherit toolchain-funcs eutils elisp-common perl-module bash-completion
@@ -110,36 +110,30 @@ src_unpack() {
exportmakeopts
}
-src_compile() {
+git_emake() {
emake ${MY_MAKEOPTS} \
DESTDIR="${D}" \
OPTCFLAGS="${CFLAGS}" \
OPTLDFLAGS="${LDFLAGS}" \
prefix=/usr \
htmldir=/usr/share/doc/${PF}/html \
- || die "make failed"
+ "$@"
+}
+
+src_compile() {
+ git_emake || die "emake failed"
if use emacs ; then
elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
fi
if use perl && use cgi ; then
- emake ${MY_MAKEOPTS} \
- DESTDIR="${D}" \
- OPTCFLAGS="${CFLAGS}" \
- OPTLDFLAGS="${LDFLAGS}" \
- prefix=/usr \
- htmldir=/usr/share/doc/${PF}/html \
- gitweb/gitweb.cgi || die "make gitweb/gitweb.cgi failed"
+ git_emake \
+ gitweb/gitweb.cgi || die "emake gitweb/gitweb.cgi failed"
fi
}
src_install() {
- emake ${MY_MAKEOPTS} \
- DESTDIR="${D}" \
- OPTCFLAGS="${CFLAGS}" \
- OPTLDFLAGS="${LDFLAGS}" \
- prefix=/usr \
- htmldir=/usr/share/doc/${PF}/html \
+ git_emake \
install || \
die "make install failed"
@@ -283,7 +277,8 @@ src_test() {
cd "${S}"
# Now run the tests
einfo "Start test run"
- emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+ git_emake \
+ test || die "tests failed"
}
showpkgdeps() {