summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 11:22:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 11:22:19 +0000
commitda78904e9f7a9e3b15cfc7b9128c6fe7ebd1e672 (patch)
tree7d680b4205c3492e6376f2a7517e594663f852cb /dev-util/insight
parentrepoman'd (diff)
downloadgentoo-2-da78904e9f7a9e3b15cfc7b9128c6fe7ebd1e672.tar.gz
gentoo-2-da78904e9f7a9e3b15cfc7b9128c6fe7ebd1e672.tar.bz2
gentoo-2-da78904e9f7a9e3b15cfc7b9128c6fe7ebd1e672.zip
repoman'd
Diffstat (limited to 'dev-util/insight')
-rw-r--r--dev-util/insight/insight-5.1.1.ebuild41
1 files changed, 19 insertions, 22 deletions
diff --git a/dev-util/insight/insight-5.1.1.ebuild b/dev-util/insight/insight-5.1.1.ebuild
index a044b11d1f31..b449b92e73c3 100644
--- a/dev-util/insight/insight-5.1.1.ebuild
+++ b/dev-util/insight/insight-5.1.1.ebuild
@@ -1,36 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-5.1.1.ebuild,v 1.2 2002/07/11 06:30:25 drobbins Exp $
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-5.1.1.ebuild,v 1.3 2002/07/23 11:22:19 seemant Exp $
+S=${WORKDIR}/${P}
DESCRIPTION="A graphical interface to the GNU debugger"
HOMEPAGE="http://sources.redhat.com/insight/index.html"
-
SRC_URI="ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2"
-S="${WORKDIR}/${P}"
-DEPEND="virtual/glibc
- sys-libs/ncurses
- nls? ( sys-devel/gettext )"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
INSIGHTDIR="/opt/insight"
src_compile() {
- local myconf
- if [ -z "`use nls`" ]; then
- myconf="--disable-nls"
- fi
- ./configure \
- --host="${CHOST}" \
- --prefix="${INSIGHTDIR}" \
- --without-included-regex \
- --without-included-gettext \
- ${myconf} || die
- emake || die
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf ${myconf} || die
+ emake || die
}
src_install () {
- make prefix="${D}${INSIGHTDIR}" install || die
- dosym /opt/insight/bin/gdb /opt/insight/bin/insight
- insinto /etc/env.d
- doins "${FILESDIR}/99insight"
+ make prefix="${D}${INSIGHTDIR}" install || die
+ dosym /opt/insight/bin/gdb /opt/insight/bin/insight
+ insinto /etc/env.d
+ doins "${FILESDIR}/99insight"
}