summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-09-21 21:38:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-09-21 21:38:38 +0000
commit1d4d2fc678c1d05dc223cfd2058cdfa627f9ea42 (patch)
tree30277b97e15e892469f7dccbdb3d429e8f91a652 /dev-util/meld
parentupdated for bug #237495 (forces python when wxwindows is enabled) (diff)
downloadgentoo-2-1d4d2fc678c1d05dc223cfd2058cdfa627f9ea42.tar.gz
gentoo-2-1d4d2fc678c1d05dc223cfd2058cdfa627f9ea42.tar.bz2
gentoo-2-1d4d2fc678c1d05dc223cfd2058cdfa627f9ea42.zip
respect LINGUAS, bug #183086.
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'dev-util/meld')
-rw-r--r--dev-util/meld/ChangeLog5
-rw-r--r--dev-util/meld/meld-1.2.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-util/meld/ChangeLog b/dev-util/meld/ChangeLog
index 6f6bb9da6681..167fb73bcdc8 100644
--- a/dev-util/meld/ChangeLog
+++ b/dev-util/meld/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/meld
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.80 2008/07/25 16:39:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/ChangeLog,v 1.81 2008/09/21 21:38:38 eva Exp $
+
+ 21 Sep 2008; Gilles Dartiguelongue <eva@gentoo.org> meld-1.2.ebuild:
+ respect LINGUAS, bug #183086.
25 Jul 2008; Raúl Porcel <armin76@gentoo.org> meld-1.1.5.1-r1.ebuild:
alpha/ia64/sparc/x86 stable wrt #232337
diff --git a/dev-util/meld/meld-1.2.ebuild b/dev-util/meld/meld-1.2.ebuild
index 49ca15c5530b..91f97901dafa 100644
--- a/dev-util/meld/meld-1.2.ebuild
+++ b/dev-util/meld/meld-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.2.ebuild,v 1.1 2008/07/19 17:43:30 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/meld/meld-1.2.ebuild,v 1.2 2008/09/21 21:38:38 eva Exp $
inherit python gnome2 eutils multilib
@@ -44,6 +44,14 @@ src_unpack() {
# don't run scrollkeeper (with the wrong path), leave that to gnome2.eclass #145833
sed -i -e '/scrollkeeper-update/s/\t/&#/' help/*/GNUmakefile
+
+ strip-linguas -i "${S}/po"
+ local mylinguas=""
+ for x in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${x}.po"
+ done
+
+ sed -i -e "s/PO:=.*/PO:=${mylinguas}/" po/GNUmakefile
}
src_compile() {