summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2009-11-16 21:23:10 +0000
committerDirkjan Ochtman <djc@gentoo.org>2009-11-16 21:23:10 +0000
commitfba7447b6e9dd15e37ce1908bf779ce942356d2b (patch)
treedc25abceb43f08f6380cc903815ca6b148d4ae10 /dev-util/mercurial
parentRemove masked khdasmon (diff)
downloadgentoo-2-fba7447b6e9dd15e37ce1908bf779ce942356d2b.tar.gz
gentoo-2-fba7447b6e9dd15e37ce1908bf779ce942356d2b.tar.bz2
gentoo-2-fba7447b6e9dd15e37ce1908bf779ce942356d2b.zip
Version bump: dev-util/mercurial-1.4.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mercurial')
-rw-r--r--dev-util/mercurial/ChangeLog7
-rw-r--r--dev-util/mercurial/mercurial-1.4.ebuild121
2 files changed, 127 insertions, 1 deletions
diff --git a/dev-util/mercurial/ChangeLog b/dev-util/mercurial/ChangeLog
index 876f1cc8bff0..71f021a105d9 100644
--- a/dev-util/mercurial/ChangeLog
+++ b/dev-util/mercurial/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mercurial
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.110 2009/11/03 19:20:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/ChangeLog,v 1.111 2009/11/16 21:23:10 djc Exp $
+
+*mercurial-1.4 (16 Nov 2009)
+
+ 16 Nov 2009; Dirkjan Ochtman <djc@gentoo.org> +mercurial-1.4.ebuild:
+ Version bump to Mercurial 1.4, just released.
03 Nov 2009; Raúl Porcel <armin76@gentoo.org> mercurial-1.3.1-r1.ebuild:
alpha/ia64/sparc stable wrt #289998
diff --git a/dev-util/mercurial/mercurial-1.4.ebuild b/dev-util/mercurial/mercurial-1.4.ebuild
new file mode 100644
index 000000000000..82698e2fe675
--- /dev/null
+++ b/dev-util/mercurial/mercurial-1.4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mercurial/mercurial-1.4.ebuild,v 1.1 2009/11/16 21:23:10 djc Exp $
+
+EAPI=2
+
+inherit bash-completion elisp-common flag-o-matic eutils distutils
+
+DESCRIPTION="Scalable distributed SCM"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="http://mercurial.selenic.com/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bugzilla emacs gpg test tk zsh-completion"
+
+CDEPEND=">=dev-lang/python-2.4[threads]"
+RDEPEND="${CDEPEND}
+ bugzilla? ( dev-python/mysql-python )
+ gpg? ( app-crypt/gnupg )
+ tk? ( dev-lang/tk )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${CDEPEND}
+ emacs? ( virtual/emacs )
+ test? ( app-arch/unzip
+ dev-python/pygments )"
+
+PYTHON_MODNAME="${PN} hgext"
+SITEFILE="70${PN}-gentoo.el"
+
+src_compile() {
+ filter-flags -ftracer -ftree-vectorize
+
+ distutils_src_compile
+
+ if use emacs; then
+ cd "${S}"/contrib
+ elisp-compile mercurial.el || die "elisp-compile failed!"
+ fi
+
+ rm -rf contrib/{win32,macosx}
+}
+
+src_install() {
+ distutils_src_install
+
+ dobashcompletion contrib/bash_completion ${PN}
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh_completion _hg
+ fi
+
+ rm -f doc/*.?.txt
+ dodoc CONTRIBUTORS PKG-INFO README doc/*.txt
+ cp hgweb*.cgi "${D}"/usr/share/doc/${PF}/
+
+ dobin contrib/hgk
+ dobin contrib/hg-ssh
+
+ rm -f contrib/hgk contrib/hg-ssh
+
+ rm -f contrib/bash_completion
+ cp -r contrib "${D}"/usr/share/doc/${PF}/
+ doman doc/*.?
+
+ cat > "${T}/80mercurial" <<-EOF
+HG=/usr/bin/hg
+EOF
+ doenvd "${T}/80mercurial"
+
+ if use emacs; then
+ elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+}
+
+src_test() {
+ local testdir="${T}/tests"
+ mkdir -p -m1777 "${testdir}" || die
+ cd "${S}/tests/"
+ rm -rf *svn* # Subversion tests fail with 1.5
+ rm -f test-archive # Fails due to verbose tar output changes
+ rm -f test-convert-baz* # GNU Arch baz
+ rm -f test-convert-cvs* # CVS
+ rm -f test-convert-darcs* # Darcs
+ rm -f test-convert-git* # git
+ rm -f test-convert-mtn* # monotone
+ rm -f test-convert-tla* # GNU Arch tla
+ rm -f test-doctest* # doctest always fails with python 2.5.x
+ if [[ ${EUID} -eq 0 ]]; then
+ einfo "Removing tests which require user privileges to succeed"
+ rm -f test-command-template # Test is broken when run as root
+ rm -f test-convert # Test is broken when run as root
+ rm -f test-lock-badness # Test is broken when run as root
+ rm -f test-permissions # Test is broken when run as root
+ rm -f test-pull-permission # Test is broken when run as root
+ fi
+ einfo "Running Mercurial tests ..."
+ python run-tests.py --tmpdir="${testdir}" || die "test failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog "If you want to convert repositories from other tools using convert"
+ elog "extension please install correct tool:"
+ elog " dev-util/cvs"
+ elog " dev-util/darcs"
+ elog " dev-util/git"
+ elog " dev-util/monotone"
+ elog " dev-util/subversion"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ use emacs && elisp-site-regen
+}